PowerMax: Problemas de configuración de SRDF SRA con ID de dispositivo duplicados en grupos de protección de VMware SRM

Summary: Si dos dispositivos de arreglo en dos pares de arreglos diferentes tienen el mismo ID de dispositivo, por ejemplo, 0003A, VMware no puede identificar correctamente el grupo de protección para un par. Por ejemplo, el arreglo A y el arreglo B tienen pares con el arreglo C y, posiblemente, con el arreglo D. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Este ejemplo se toma de un laboratorio:

si dos dispositivos de arreglo en dos pares de arreglos diferentes tienen el mismo ID de dispositivo, como 0003A, VMware no puede identificar correctamente el grupo de protección para un par.

Por ejemplo, tres arreglos (aunque podrían tener cuatro), A, B y C. Han configurado pares entre A y C y B y C. Por casualidad, un conjunto de pares de cada uno tiene el mismo ID de dispositivo en A y C: 

Pares de la A a la C: 0003A - 001B8
Pares de B a C: 0003A - 000F0

Estos son pares independientes y SRDF SRA no tiene problemas para reconocerlos, como se muestra a continuación:
Pares de arreglos 

Después de crear el grupo de protección para cada conjunto de pares, navegue por cada uno y busque los pares. Uno de los grupos de protección no reconocerá los pares de dispositivos o, a veces, mostrará el par incorrecto.

Grupo de protección 

Cause

La causa del problema parece ser el código de VMware SRM. Se basa en el ID del dispositivo en lugar de utilizar el NAA (o WWN), que es único en cada arreglo.

Resolution

La solución alternativa actual es transferir mediante Storage vMotion las VM de uno de los pares infractores a un nuevo par y, a continuación, eliminar el par para que no se use en VMware. Con una planificación cuidadosa, se pueden evitar ID duplicados.

VMware reconoció el problema y la corrección se incluirá en SRM 8.6. La fecha de lanzamiento actual es junio de 2022, pero está sujeta a cambios. Han indicado que pueden proporcionar backports a SRM 8.4/8.5 después de eso.

Affected Products

Symmetrix, VMAX, PowerMax 2000, PowerMax 2500, PowerMax 8000, PowerMax 8500, VMware
Article Properties
Article Number: 000195144
Article Type: Solution
Last Modified: 13 Mar 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.