PowerStore:无法在 ESXi 7.0.3 上使用具有 Emulex HBA 的 NVMe 协议创建数据存储区

Summary: 在 ESXi 7.0.3 上使用 NVMe 协议和 Emulex HBA 创建数据存储失败。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

数据存储创建失败,并显示错误:
主机配置期间出错。作失败,诊断报告:无法创建文件系统,请查看 VMkernel 日志以了解更多详细信息:无法检查支持 ATS 的设备 /dev/disks/eui.80931ecd24b1519e8ccf096xxxxxxxx:1

ESXI 日志显示: 
  • vmkernel.log:
2022-01-05T19:25:26.607Z cpu40:2100041)WARNING:NvmeScsi:172: 路径 vmhba64:C0:T2:L43 上的 SCSI作码0x85 (0x45d9915cc108) 到 命名空间 eui.66f9071930fa9d598ccf09680xxxxxxx 失败,NVMe 错误状态:0x1转换为 SCSI 错误   <--在这里,我们可以看到卷的设备 ID 以及生成 SCSI 感知代码的 ID。

2022-01-05T19:25:26.607Z cpu40:2100041)WARNING:H:0x0 D:0x2 P:0x0 Valid sense data: < 0x5 0x20 0x0--在这里,我们看到 NVMe 错误和 SCSI 感知代码,该代码表示存在检查条件、非法请求和无效的命令作代码。   
  • vmwarning.log:
2022-01-05T16:10:06.737Z cpu11:2105127)WARNING: brcmnvmefc: nvmefcGetRemotePort:2580:1073 — 获取远程端口失败   <-----这些错误通过流式传输到日志中,指示存在连接问题。  
 
将 ESXi 日志上传到 http://10.2XX.1XX.2XX/cxxtx.html,您可以搜索 lpfc 并查看主机 HBA 驱动程序和固件版本。 
lpfc 12.8.511.0-1OEM.700.1.0.15843807 EMU VMware 认证 2021-09-22   <--以下是 HBA 的驱动程序版本。

Cause

低于 14.0.326.12-1OEM.700.1.0.15843807 的 Emulex HBA 版本不支持 ESXi 7.0.3。Emulex 在此最新的驱动程序升级中增加了对 ESXi 7.0.3 的支持。请参阅 Emulex 版本 14.0.321.12 的发行说明。

以下是 VMware 兼容性指南的链接,该指南指出 Emulex HBA 唯一支持的驱动程序是代码 14.0.326.12。


https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=41220&deviceCategory=io&details=1&SSID=e323&page=1&display_interval=10&sortColumn=Partner&sortOrder=Asc您还可以查看 Emulex HBA 白页中的代码 14.0.326.12,这表示它添加了对 ESXi 7.0.3 的支持。下面是白页第 1 页的输出。  

“添加了对 VMware ESXi 7.0 U3作系统的支持。”

Resolution

将 Emulex HBA 驱动程序升级到版本 14.0.326.12。

Affected Products

Entry Level & Midrange, PowerStore

Products

Storage, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
Article Properties
Article Number: 000195196
Article Type: Solution
Last Modified: 08 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.