PowerEdge: Sistema operacional Linux em execução de recursos causando uma reinicialização

Summary: O SUSE Linux Enterprise Server for SAP foi reinicializado intermitentemente, uma ou duas vezes por semana.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

O SUSE Linux Enterprise Server for SAP foi reinicializado intermitentemente, uma ou duas vezes por semana. Trata-se de servidores de cluster de 2 nós em execução com o SAP HANA.
Nos logs do cluster, indicou que o nó primário reinicializou devido à falha monitorada pelos recursos do cluster.

Cause

Os logs foram analisados antes da reinicialização e descobriram o seguinte.


resouces_unavailable 
 

Resolution

Com o erro "Recurso temporariamente indisponível", isso indica que o sistema operacional estava ficando sem recursos.
Nesse caso, verifique o relatório SAR antes da reinicialização do servidor.

00:00:01      runq-sz  plist-sz   ldavg-1   ldavg-5  ldavg-15   blocked
16:40:01           20     32595      9.01      9.97      5.46         0
16:50:01           15     32611      1.49      2.81      3.70         0

Há 32.611 processos em execução. No entanto, os processos máximos permitidos são:
kernel.pid_max = 32768  (Obter isso do arquivo de log env.txt ou a partir do comando do SO "sysctl -a | grep pid_max"
Então, isso concluiu que o servidor atingiu o máximo de processos permitidos. O cliente pode verificar com o comando "ps aux" para analisar se todos os processos são necessários ou pode ser que os processos não parados corretamente e continuar criando novos processos.
Os processos desnecessários corrigidos corrigiram o problema

Affected Products

SUSE Linux Enterprise Server 12, Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 8, SUSE Linux Enterprise Server 15

Products

OEMR R240, OEMR R340, OEMR R350, OEMR R360, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415 , OEMR R750, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R960, PowerEdge R240, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R960 ...
Article Properties
Article Number: 000201809
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.