OpenManage Server Administrator Web Kullanıcı Arayüzü, Ana Bilgisayar Adı Alt Çizgili Olduğunda Sunuculara Yüklenemiyor

Summary: Ana bilgisayar adında alt çizgi bulunan bir sunucuda OpenManage Server Administrator (OMSA) web arayüzüne erişimi geri yükleme talimatları

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ana bilgisayar adının alt çizgi içerdiği bir sunucuda OpenManage Server Administrator (OMSA) web arayüzüne erişilemiyor. Örneğin, sunucunun ana bilgisayar adı "FS_1.domain.local"dır. Alınan mesaj genellikle "This site can't be reached" or "ERR_CONNECTION_CLOSED " çıktısıdır. DSM SA Connection Service, beklendiği gibi bağlantı noktası 1311'deki bağlantıları çalıştırıyor ve dinliyor.

Cause

Alt çizgiler, RFC 1912'de belgelendiği gibi Etki Alanı Adı Sistemi (DNS) ana bilgisayar adları için geçerli bir karakter değildir.

Bu köprü bağlantı sizi Dell Technologies dışındaki bir web sitesine yönlendirir.

https://datatracker.ietf.org/doc/html/rfc1912#section-2.1Sonuç olarak OMSA, yükleme sırasında kendinden imzalı bir sertifika oluşturamaz ve hizmetlerini geçerli bir TLS yapılandırması olmadan başlatır. Bağlantı hizmeti hala çalışıyor ve başlatma sırasında 1311 numaralı bağlantı noktasına bağlanıyor ancak bağlantıları kabul etmiyor.

Resolution

Seçenek A
Sunucunun adını yalnızca harf, sayı veya kısa çizgi içeren yeni bir adla değiştirin, ardından OMSA'yı kaldırıp yeniden yükleyin.
 
Seçenek B
Geçerli bir sertifika yükleyin ve OMSA'ya ana bilgisayar adı yerine IP adresiyle erişin. Etkilenen sunucuda aşağıdaki OMConfig komutunu çalıştırmak, kendinden imzalı yeni bir sertifika oluşturur:
omconfig preferences webserver attribute=gennewcert cn=<servername> org=Dell ou=ESG location=RoundRock state=TX country=US validity=3650 keysize=2048 algorithm=SHA512 webserverrestart=true
 
servername>"< değerini desteklenen herhangi bir değerle değiştirin. En basit seçenek, alt çizgileri kaldırılmış olarak sunucunun geçerli adını kullanmaktır.

Affected Products

OpenManage Server Administrator
Article Properties
Article Number: 000221443
Article Type: Solution
Last Modified: 10 Apr 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.