PowerStore: Het gebruik van het bestandssysteem dat is verkregen via pstcli- of REST API-opdrachten wordt niet bijgewerkt

Summary: Klanten die pstcli-opdrachtscripts of REST API-opdrachtscripts uitvoeren om de grootte van het bestandssysteem te gebruiken, krijgen de bijgewerkte waarden niet, tenzij ze het gebruik handmatig vernieuwen door de opdracht refresh_usage uit te voeren of door naar de GUI te gaan en het gebruik voor dat specifieke bestandssysteem weer te geven. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De pstcli- en Rest API-opdrachten retourneren dezelfde gebruikswaarde van het bestandssysteem, zelfs als er nieuwe data naar het bestandssysteem worden geschreven, wanneer een apparaat PowerStore OS lager dan 4.0.0.x

Pstcli uitvoert - voorbeeld: 

- before adding files:
cli> file_system -name test show -select name,size_used
name      = test
size_used = 1621098496 (1.50G)


- after adding files

cli> file_system -name test show -select name,size_used
name      = test
size_used = 1621098496 (1.50G)  <----- notice the size didn't change. 

cli> file_system -name test refresh_usage
Success



cli> file_system -name test show -select name,size_used
name      = test
size_used = 3948937216 (3.67G)    <------ notice the newly updated used space.

 

 

 


 

Cause

Er is een probleem in PowerStoreOS onder versie 4.0.0.x waardoor het gebruik van het bestandssysteem handmatig moet worden vernieuwd. 

Resolution

Tijdelijke oplossing: 
Voer een refresh_usage opdracht uit:

PstCLI bijvoorbeeld:

cli> file_system -name <filesystem name> refresh_usage


Optie curl-opdracht:

curl -k --user Username:Password -X POST https://<Management IP>:443/api/rest/file_system<filesystem ID>/refresh_usage -H "dell-visibility:internal"


GUI-optie:
ga naar het bestandssysteem dat u handmatig wilt bijwerken met behulp van de GUI.  Zodra u op het bestandssysteem klikt, wordt het refresh_usage commando uitgevoerd. 

Oplossing:
Dit probleem is opgelost in PowerStoreOS 4.0.0.x en hoger.

Affected Products

PowerStore, PowerStore 1000T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T, PowerStoreOS
Article Properties
Article Number: 000227830
Article Type: Solution
Last Modified: 26 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.