Avamar:“mccli backup validate”命令不适用于 VMware 映像备份
Summary: 本文讨论在 VMware 映像备份中使用“mccli backup validate”命令的限制。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
使用 VMware 映像备份时,管理控制台命令行界面 (MCCLI) 备份验证不起作用。
而 mccli backup validate 开始:
admin@av-server:~/>: mccli backup validate --name=/vCenterProd/VirtualMachines/VM-Prod-01 --labelNum=10 --plugin=1016 0,22315,client validate scheduled Attribute Value ----------- ---------------------------------------------------- client /vCenterProd/VirtualMachines/VM-Prod-01 activity-id 9172719295543209 admin@av-server:~/>:
经过验证的作业保留在 Waiting-Client 中,直到其 Timed Out - Start:
admin@av-server:~/>: mccli activity show | grep Timed | grep Validate 9172719295543209 Timed Out - Start 0 2024-09-24 10:49 CDT 00h:09m:56s 2024-09-24 10:59 CDT Validate 0 bytes 0% VM-Prod-01_NqZVjpzBOs6dD9iX6AhgIA /vCenterProd/VirtualMachines admin@av-server:~/>:
此功能适用于其他类型的备份。
Linux 文件系统备份示例:
admin@av-server:~/>: mccli backup validate --name=/clients/linux-prod.lab.com --labelNum=7 --plugin=1001 0,22315,client validate scheduled Attribute Value ----------- --------------------------------------------- client /clients/linux-prod.lab.com activity-id 9173376417059609 admin@av-server:~/>: admin@av-server:~/>: mccli activity show | grep Validate 9173376417059609 Completed 0 2024-12-09 11:09 CST 00h:00m:55s 2024-12-09 11:10 CST Validate 68.4 MB 0.2% linux-prod.lab.com /clients admin@av-server:~/>:
Cause
VMware 映像备份需要更多信息才能使备份验证正常运行。但是,mccli 不支持包含额外的参数。
Resolution
使用 Avamar 用户界面 (AUI) 或 Avamar 管理员控制台 (UI) 验证 VMware 映像备份。
另一种解决方案是使用 avtar validate 命令确认该锁定已释放。
-
收集客户端名称和备份标签号。
-
以管理员身份登录到 Avamar Server。
-
运行验证命令:
avtar --validate --labelnum=<backup label number> --acnt=<client fully qualified name>
示例:
admin@av-server:~/>: avtar --validate --labelnum=2 --acnt=/clients/vCenter1/esctest_LKar3Z6AMGWcRP1mSd8kjg avtar Info <5551>: Command Line: /usr/local/avamar/bin/avtar.bin --flagfile=/usr/local/avamar/etc/usersettings.cfg --server=av-server --vardir=/usr/local/avamar/var --bindir=/usr/local/avamar/bin --id=root --password=**************** --vardir=/usr/local/avamar/var --bindir=/usr/local/avamar/bin --sysdir=/usr/local/avamar/etc --validate --sequencenumber=2 --account=/clients/vCenter1/esctest_LKar3Z6AMGWcRP1mSd8kjg avtar Info <7977>: Starting at 2024-11-19 17:29:42 IST [avtar Dec 8 2023 07:07:43 19.10.100-135 Linux-x86_64] avtar Info <6555>: Initializing connection avtar Info <5552>: Connecting to Avamar Server (av-server) avtar Info <5554>: Connecting to one node in each datacenter avtar Info <5583>: Login User: "root", Domain: "default", Account: "/clients/vCenter1/esctest_LKar3Z6AMGWcRP1mSd8kjg" avtar Info <5580>: Logging in on connection 0 (server 0) avtar Info <5582>: Avamar Server login successful avtar Info <10632>: Using Client-ID='00be5081c15db98be5f496754fb9ae970509ef05' avtar Info <5550>: Successfully logged into Avamar Server [19.10.0-135] avtar Info <5295>: Starting validate at 2024-11-19 17:29:42 IST as "admin" on "av-server.lab.com" (2 CPUs) [19.10.100-135] avtar Info <41359>: Backup #2 had been created by avtar version 19.10.100-135 as plugin 3016-VMWare Image avtar Info <5949>: Backup file system character encoding is UTF-8. avtar Info <8745>: Backup from Linux host "/clients/vCenter1/esctest_LKar3Z6AMGWcRP1mSd8kjg" (a4t134.lab.com) with plugin 3016 - Windows VMWare Image avtar Info <5538>: Backup #2 label "MOD-1731919024567#1" timestamp 2024-11-18 14:09:38 IST, 0 files, 40.00 GB avtar Info <40107>: Validating location information avtar Info <40121>: Checking location information avtar Info <5262>: Validate completed avtar Info <7924>: Examined selection(s) with 40.00 GB (8 files, 3 directories) in 0.34 minutes: 7,093 GB/hour avtar Info <7883>: Finished at 2024-11-19 17:30:03 IST, Elapsed time: 0000h:00m:20s avtar Info <6645>: Not sending wrapup anywhere. avtar Info <5314>: Command completed (exit code 0: success) admin@av-server:~/>:
Affected Products
Avamar, Avamar ServerArticle Properties
Article Number: 000258379
Article Type: Solution
Last Modified: 03 Dec 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.