PowerFlex Import Tool – Fel i PFxM: Kunde inte create_ldap_user under distributionen

Summary: Utan LDAP-konfiguration misslyckas PowerFlex Manager under distributionen och det går inte att create_ldap_user och distributionen misslyckas.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenario

 Kundinformation importeras till PFxM med hjälp av ett PowerFlex-importverktyg. Distributionsförsök har gjorts. Distributionen misslyckas med ldap-fel. Från deployment.log:

ERROR [2024-08-05T17:21:41.107092] 75572: type/server.rb:3920:in `create_ldap_user': rackserver-2s6rm34: Could not create_ldap_user NoMethodError: undefined method `downcase' for nil:NilClass

Från motsvarande exception.log:

#
  
/opt/asm-deployer/lib/asm/type/server.rb:3921:in `create_ldap_user'
/opt/asm-deployer/lib/asm/type/server.rb:2518:in `provision_server!'
/opt/asm-deployer/lib/asm/service_deployment.rb:5530:in `process_server_with_types'
/opt/asm-deployer/lib/asm/service_deployment.rb:3171:in `process_server'
/opt/asm-deployer/lib/asm/service_deployment.rb:1539:in `block in create_component_thread'

 

Påverkan

Det går inte att distribuera resursgruppen.

Cause

Bugg i PowerFlex Import Tool före 4.2.0. Där inloggningsuppgifter importerades med fel användarnamn. Den använde root/admin/secadmin och placerade också ordet NULL i domänfältet. Det innebär att PFxM-automatisering kastas in i LDAP-konfigurationskodsekvensen  

Resolution

Ta bort inloggningsuppgifter och återskapa dem manuellt med hjälp av användargränssnittet.  

Ett annat alternativ är att uppgradera PowerFlex Import Tool 4.2.0 eller senare.

Berörd version 

Alla PFxM-versioner

Fast version

PFxM → Ej tillämpligt

PowerFlex-importverktyg 4.2.0

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000269022
Article Type: Solution
Last Modified: 26 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.