NetWorker NMC 19.13: Impossibile avviare l'interfaccia utente NMC "No Suitable JVM found"

Summary: Impossibile avviare NetWorker Management Console (NMC) in NetWorker 19.13 e versioni successive.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Management Console (NMC) 19.13 (o versione successiva):

Unable to launch NMC user interface.

Avvio del file scaricato gconsole.jnlp ha portato a un Read error.

Impossibile analizzare JNLP

Avvio di NMC dalla riga di comando con il comando javaws https://NMC-server:9000/gconsole.jnlp Esito negativo con No suitable JVM was found to start the application.

Nessuna JVM adatta

Cause

L'errore è dovuto a un conflitto di risoluzione dei nomi che coinvolge due server NetWorker che condividono lo stesso nome host ma assegnati a indirizzi IP diversi. Ciò causava ambiguità durante la risoluzione dei nomi host e influiva sull'avvio di NMC.

Resolution

Rimossa l'opzione IPADDR_REPLACE_AT_RUNTIME stringa dal gconsole.jnlp per eliminare la sostituzione dinamica degli IP e garantire una risoluzione coerente dei nomi host.

  • Linux: /opt/lgtonmc/web/gconsole.jnlp
  • Windows (impostazione predefinita): C:\Program Files\EMC NetWorker\Management\GST\web\gconsole.jnlp

Righe interessate modificate (l'indirizzo IP mostrato è un esempio):

DA:

codebase="https://IPADDR_REPLACE_AT_RUNTIME(192.168.9.150):9000/" 
<argument>IPADDR_REPLACE_AT_RUNTIME(192.168.9.150)</argument>

A:

codebase="https://192.168.9.150:9000/" 
<argument>192.168.9.150</argument>

Queste righe sono state aggiornate in modo da utilizzare un indirizzo IP statico al fine di evitare conflitti con il server NetWorker con nome simile.

Assicurarsi che l'host client NMC (host che avvia NMC) sia in grado di risolvere correttamente l'indirizzo dei server NMC. Se il client NMC non risolve correttamente l'host, il programma di avvio NMC potrebbe segnalare "Unable to connect to server hostname, make sure the server is running".

  1. Verificare che l'host del client NMC sia in grado di risolvere il nome host (prompt di PowerShell): tnc hostname -p 9000
  2. Se il comando precedente non riesce a connettersi ma il server è raggiungibile dall'IP, creare una voce del file hosts per il server.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000361215
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.