SourceOne Email Management - 인덱스를 ISYS에서 ElasticSearch로 변환한 후 날짜별로 검색할 때 검색 결과 생략
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Symptoms
ISYS 아카이브 폴더에 ElasticSearch를 구성하고 해당 인덱스 세트를 ElasticSearch 유형으로 변환했습니다.
변환 후 변환된 인덱스에서 특정 날짜 범위를 검색하면 결과가 생성되지 않거나 특정 날짜에 대한 항목이 결과에 표시되지 않습니다.
SourceOne 로그 또는 웹 검색에 오류가 기록되지 않습니다.
이 문제는 ISYS 아카이브 폴더에서 ElasticSearch로 마이그레이션한 고객에게만 영향을 미칩니다.
마이그레이션하는 동안 ISYS 인덱스는 1개의 단일 ElasticSearch 인덱스로 병합되지만 MsgStartDate 및 MsgEndDate를 올바르게 업데이트하지 못합니다.
MsgStartDate 및 MsgEndDate는 인덱스 세트에 병합된 최신 인덱스 세트를 기반으로 잘못 설정되지만 ElasticSearch 인덱스 세트 내의 모든 메시지의 날짜 범위를 기반으로 설정해야 합니다.
날짜 검색 조건이 MsgStartDate 및 MsgEndDate를 벗어나면 인덱스가 검색에 포함되지 않으므로 이 인덱스의 결과가 제공되지 않습니다.
예:
2017년 2월의 ElasticSearch 인덱스가 MsgStartDate 20-02-2017 및 MsgEndDate 28-02-2017을 잘못 설정했습니다.
사용자가 2017년 1월 1일과 2월 15일의 날짜 범위로 검색하는 경우 2월 색인이 검색어에 포함되지 않으므로 1월에 찾은 항목만 결과에 표시됩니다.
Cause
이 문제는 소프트웨어 결함으로 인해 발생합니다.
Resolution
이 문제는 7.2.5.5088 이상의 핫픽스 번들 또는 서비스 팩 버전에서 해결되었습니다. (7.2.5 GA)입니다.
이 문제는 SourceOne Email Management 7.2.5.6201 이상의 HFB(Hotfix Bundle) 또는 서비스 팩 버전에서 해결되었습니다. (7.2.6 + HFB 3)
핫픽스 번들 및 서비스 팩 키트는 https://www.dell.com/support 를 통해 다운로드할 수 있습니다. 필요한 소프트웨어
에 액세스하려면 '드라이버 및 다운로드'를 선택합니다.* 핫픽스는 이 문제가 해결되었을 때 사용할 수 있었던 제품의 최신 패치 또는 서비스 팩 버전에만 사용할 수 있습니다.
** HFB(Hot Fix Bundle)를 설치할 때 모든 수정 사항이 올바르게 적용되려면 모든 HFB가 올바른 순서로 설치되어야 합니다.
*** 위에서 설명한 문제를 포함하여 현재 해결된 모든 문제가 해결될 수 있도록 항상 최신 버전의 SourceOne 릴리스, 서비스 팩 및 핫픽스 번들로 업그레이드하는 것이 좋습니다.
이 문제는 SourceOne Email Management 7.2.5.6201 이상의 HFB(Hotfix Bundle) 또는 서비스 팩 버전에서 해결되었습니다. (7.2.6 + HFB 3)
핫픽스 번들 및 서비스 팩 키트는 https://www.dell.com/support 를 통해 다운로드할 수 있습니다. 필요한 소프트웨어
에 액세스하려면 '드라이버 및 다운로드'를 선택합니다.* 핫픽스는 이 문제가 해결되었을 때 사용할 수 있었던 제품의 최신 패치 또는 서비스 팩 버전에만 사용할 수 있습니다.
** HFB(Hot Fix Bundle)를 설치할 때 모든 수정 사항이 올바르게 적용되려면 모든 HFB가 올바른 순서로 설치되어야 합니다.
*** 위에서 설명한 문제를 포함하여 현재 해결된 모든 문제가 해결될 수 있도록 항상 최신 버전의 SourceOne 릴리스, 서비스 팩 및 핫픽스 번들로 업그레이드하는 것이 좋습니다.
Additional Information
이 문제는 FTindex 테이블의 MsgStartDate 및 MsgEndDate가 ISYS에서 ElasticSearch로 변환하는 동안 ElasticSearch 인덱스로 직접 전송된 쿼리를 기반으로 올바르게 설정되도록 수정되었습니다.
FTIndex 테이블 내의 잘못된 날짜 범위로 인해 발생하는 문제를 해결하기 위해 인덱스 유효성 검사 기능에 변경 사항이 구현되었습니다. 인덱스 유효성 검사 레벨 1은 ElasticSearch 인덱스 내 문서의 실제 날짜 범위와 비교하여 FTIndex 날짜 범위를 확인하고 ElasticSearch와 일치하도록 필요한 경우 FTIndex 날짜 범위를 업데이트합니다.
인덱스 유효성 검사가 시스템에 이미 구성된 경우 인덱스의 수동 검사를 트리거해야 합니다. 설명서에 따라 예약된 인덱스 검색은 이미 검색되고 마지막 검색 이후 업데이트가 없는 인덱스 집합을 건너뜁니다.
FTIndex 테이블 내의 잘못된 날짜 범위로 인해 발생하는 문제를 해결하기 위해 인덱스 유효성 검사 기능에 변경 사항이 구현되었습니다. 인덱스 유효성 검사 레벨 1은 ElasticSearch 인덱스 내 문서의 실제 날짜 범위와 비교하여 FTIndex 날짜 범위를 확인하고 ElasticSearch와 일치하도록 필요한 경우 FTIndex 날짜 범위를 업데이트합니다.
인덱스 유효성 검사가 시스템에 이미 구성된 경우 인덱스의 수동 검사를 트리거해야 합니다. 설명서에 따라 예약된 인덱스 검색은 이미 검색되고 마지막 검색 이후 업데이트가 없는 인덱스 집합을 건너뜁니다.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000052131
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
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