AppSync: mange XIO-snaps lavet på én gang, snapper periodisk nogle LUN'er to gange, men savner andre
Summary: AppSync: Når der foretages flere XIO-snaps samtidigt, fastgør AppSync periodisk nogle LUN'er to gange, mens andre LUN'er mangler. Der er ingen konsolfejl.
Symptoms
Når flere snaps af XtremIO-kilden Lun'er er lavet samtidigt, er det muligt, at nogle Lun'er kan blive snappet to gange, mens andre Lun'er kan blive savnet helt. Der er ingen fejl i AppSync GUI. Problemet kan kun ses ved at overvåge XtremIO GUI for at se de oprettede snaps.
Problemet opstår kun, når du bruger AppSync til at lave XtremIO-snaps i et miljø, der også indeholder VPLEX. Denne tilstand er periodisk og kan ses på et eller flere systemer.
I eksemplet nedenfor skal du bemærke, at LUN 6 ikke er fastgjort, mens LUN 8 er fastgjort to gange.
| Kilde | Destination | |
| LUN 1 | LUN 1 | |
| LUN 2 | LUN 2 | |
| LUN 3 | LUN 3 | |
| LUN 4 | LUN 4 | |
| LUN 5 | LUN 5 | |
| LUN 6 | LUN 8 | |
| LUN 7 | LUN 7 | |
| LUN 8 | LUN 8 | |
| LUN 9 | LUN 9 | |
| LUN 10 | LUN 10 |
Cause
Denne problemtilstand skyldes, at XtremIO REST-forespørgsler returnerer flere WWN er for en forespørgsel for en enkelt LUN.
Når dette sker, validerer AppSync ikke det korrekte WWN og vælger det første på listen, der skal fastgøres. I eksemplet fortsatte AppSync med at fastgøre LUN 00074, selvom LUN 00010 var målet.
05-10-2017 07:26:30.000 INFO [Tråd-149 (HornetQ-client-global-threads-833118000)] [com.emc.archway.service.vplex.VPLEXServiceBean] [] [] CQ 110140 : Brugerdefinerede data til getstorageviewsinfoscontainingwwn for wwn <WWN> er: Visninger eksport volumen VPD83T3:<WWN>:
Se Array01_id_SV eksporter (7.device_XtremIO0604_LUN_00074_1_vol.VPD83T3:<WWN).>
Se Array01_id_SV eksporter (7.device_XtremIO6873_LUN_00010_1_vol.VPD83T3:<WWN).>
Resolution
Midlertidig løsning:
AppSync Engineering har leveret et hotfix til AppSync 3.1.0.2. Dette hotfix introducerer yderligere validering, så det korrekte WWN altid vælges.
Angiv disse oplysninger, når du kontakter EMC-kundesupportcenteret eller din EMC-kundeservicerepræsentant for at få teknisk assistance. Angiv løsnings-id'et.
Løsning:
AppSync Engineering er i øjeblikket ved at løse dette problem, men har ikke leveret en rettelse i en udgivet programrettelse. Denne løsning opdateres med programrettelsen, når den er blevet frigivet.