AppSync: monta kerralla tehtyä XIO-napsautusta napsahtaa ajoittain joihinkin LUN-levyihin kahdesti, mutta jättää toiset huomiotta
Summary: AppSync: Kun XIO-napsautuksia tehdään samanaikaisesti, AppSync napsauttaa joitakin LUNeja ajoittain kahdesti, kun taas toiset puuttuvat. Konsolivirheitä ei ole.
Symptoms
Kun useita XtremIO-lähteen napsautuksia LUN:t tehdään samanaikaisesti, on mahdollista, että jotkut LUN:t voidaan napsauttaa kahdesti, kun taas muut LUN:t voidaan jättää kokonaan väliin. AppSync-käyttöliittymässä ei ole virheitä. Ongelma näkyy vain seuraamalla XtremIO-käyttöliittymää nähdäksesi luodut napsautukset.
Ongelma ilmenee vain, kun XtremIO-vedoksia tehdään AppSyncillä ympäristössä, joka sisältää myös VPLEXiä. Tämä tila on ajoittainen ja saattaa ilmetä yhdessä tai useammassa levyjärjestelmässä.
Huomaa alla olevassa esimerkissä, että LUN 6 ei napsahda, kun taas LUN 8 napsahtaa kahdesti.
| Lähde | Tavoite | |
| LUN 1 | LUN 1 | |
| LUN 2 | LUN 2 | |
| LUN 3 | LUN 3 | |
| LUN 4 | LUN 4 | |
| LUN 5 | LUN 5 | |
| LUN 6 | LUN 8 | |
| LUN 7 | LUN 7 | |
| LUN 8 | LUN 8 | |
| LUN 9 | LUN 9 | |
| LUN 10 | LUN 10 |
Cause
Tämä ongelma johtuu siitä, että XtremIO REST -kyselyt palauttavat useita WWN-tunnuksia yhden LUN:n kyselylle.
Kun näin tapahtuu, AppSync ei vahvista oikeaa WWN-tunnusta vaan valitsee luettelosta ensimmäisen, johon haluat kohdistua. Esimerkissä AppSync jatkaa LUN 00074:n napsahtamista, vaikka kohteena olisi ollut LUN 00010.
05-10-2017 07:26:30.000 INFO [Thread-149 (HornetQ-client-global-threads-833118000)] [com.emc.archway.service.vplex.VPLEXServiceBean] [] [] CQ 110140 : Mukautetut tiedot getstorageviewinfoscontainingwwn WWN:lle WWN>:lle <ovat: Näkymät vievät taltion VPD83T3:<WWN:>
Näytä Array01_id_SV vienti (7,device_XtremIO0604_LUN_00074_1_vol,VPD83T3:<WWN>).
Näytä Array01_id_SV vienti (7,device_XtremIO6873_LUN_00010_1_vol,VPD83T3:<WWN>).
Resolution
Väliaikainen ratkaisu:
AppSync Engineering on toimittanut AppSync 3.1.0.2:n hotfix-korjauksen. Tämä korjaustiedosto lisää tarkistusta, jotta oikea WWN valitaan aina.
Anna nämä tiedot, kun otat yhteyttä EMC:n asiakastukikeskukseen tai EMC:n asiakaspalvelun edustajaan saadaksesi teknistä tukea. Mainitse ratkaisun tunnus.
Ratkaisu:
AppSync-tekniikka korjaa parhaillaan tätä ongelmaa, mutta ei ole tarjonnut korjausta julkaistussa korjaustiedostossa. Tämä ratkaisu päivitetään korjaustiedostolla, kun se on julkaistu.