AppSync: många XIO-ögonblicksbilder som görs på en gång, fäster ibland vissa LUN två gånger men missar andra
Summary: AppSync: När flera XIO-snapshots görs samtidigt fäster AppSync ibland vissa LUN två gånger medan andra LUN saknas. Det finns inga konsolfel.
Symptoms
När flera snapshots av XtremIO-källa Lun görs samtidigt, är det möjligt att vissa Lun kan knäppas två gånger medan andra Lun kan missas helt. Det finns inga fel i det grafiska användargränssnittet för AppSync. Problemet kan endast ses genom att övervaka XtremIO-gränssnittet för att se de snapshots som skapats.
Problemet uppstår endast när AppSync används för att skapa XtremIO-snapshots i en miljö som också innehåller VPLEX. Det här tillståndet är tillfälligt och kan ses på en eller flera matriser.
I exemplet nedan ser du att LUN 6 inte fästs medan LUN 8 fästs två gånger.
| Källa | Mål | |
| LUN 1 | LUN 1 | |
| LUN 2 | LUN 2 | |
| LUN 3 | LUN 3 | |
| LUN 4 | LUN 4 | |
| LUN 5 | LUN 5 | |
| LUN 6 | LUN 8 | |
| LUN 7 | LUN 7 | |
| LUN 8 | LUN 8 | |
| LUN 9 | LUN 9 | |
| LUN 10 | LUN 10 |
Cause
Det här problemet orsakas av att XtremIO REST-frågor returnerar flera WWN för en fråga om ett enda LUN.
När detta inträffar validerar AppSync inte rätt WWN och väljer det första i listan som ska fästas. I exemplet fortsatte AppSync att fästa LUN 00074 trots att LUN 00010 var målet.
05-10-2017 07:26:30.000 INFO [Thread-149 (HornetQ-client-global-threads-833118000)] [com.emc.archway.service.vplex.VPLEXServiceBean] [] [] CQ 110140 : Anpassade data för getstorageviewsinfoscontainingwwn för wwn <WWN> är: Vyer som exporterar volym VPD83T3:<WWN:>
Visa Array01_id_SV exporter (7,device_XtremIO0604_LUN_00074_1_vol,VPD83T3:<WWN).>
Visa Array01_id_SV exporter (7,device_XtremIO6873_LUN_00010_1_vol,VPD83T3:<WWN).>
Resolution
Tillfällig lösning:
AppSync Engineering har tillhandahållit en snabbkorrigering för AppSync 3.1.0.2. Den här snabbkorrigeringen introducerar ytterligare validering så att rätt WWN alltid väljs.
Ange den här informationen när du kontaktar EMC:s kundsupportcenter eller din EMC-kundtjänstrepresentant för att få teknisk hjälp. Ange lösnings-ID:t.
Lösning:
AppSync Engineering håller för närvarande på att lösa det här problemet, men har inte tillhandahållit någon korrigering i en släppt patch. Den här lösningen kommer att uppdateras med korrigeringsfilen när den har släppts.