Dell 노트북 또는 데스크탑이 시간이 지남에 따라 느리게 실행되는 이유와 속도를 높이는 방법
Summary: 다음 문서에서는 Dell 노트북 및 데스크탑이 시간이 지남에 따라 느려질 수 있는 이유와 디바이스에서 이 문제를 해결하는 방법에 대한 정보를 제공합니다.
Symptoms
목차:
노트북 및 데스크탑 성능 문제
소프트웨어 및 메모리
이 문서에서는 Dell 노트북 또는 데스크탑의 속도가 느려질 수 있는 이유와 이를 해결하기 위해 수행할 수 있는 몇 가지 단계에 대해 설명합니다.
노트북 또는 데스크탑이 응답하지 않거나, 사용할 수 없거나, 속도가 느려지거나, 기타 성능 문제가 있는 경우 이 도움말로 돌아오기 전에 아래 가이드를 살펴보세요.
모든 노트북과 데스크탑은 세월이 흘러도 동일한 결과를 얻기 위해 더 열심히 일합니다. 일반적으로 이것은 구매 후 몇 년 후에 발생합니다. 그러나 노트북이나 데스크톱을 몇 달 동안 사용한 후 속도가 느려지는 경우가 있습니다.
Cause
이런 문제가 발생하는 이유가 무엇입니까?
여러 가지 원인이 있습니다. 노트북이나 데스크탑을 사용하는 모든 사람은 다른 작업에 노트북이나 데스크탑을 사용하고 있습니다. 주된 대답은 시간이 지남에 따라 기계가 어떻게 사용되는지에 달려 있다는 것입니다.
소프트웨어
문제 및 원인
성능 저하를 느끼는 가장 일반적인 이유는 무엇입니까? 새 노트북, 태블릿 또는 데스크탑을 받으면 프로그램과 함께 설치된 운영 체제의 새로운 이미지가 있습니다. 공장에서부터 테스트를 거친 이미지나 빌드를 제공합니다. 랩톱 또는 데스크탑을 사용하는 동안 시간이 지남에 따라 해당 이미지가 변경되고 업데이트됩니다. 변경 사항이 많아지면 문제가 더 빨리 나타날 수 있습니다.
모든 사용자가 컴퓨터를 사용하면서 새로운 프로그램, 애플리케이션, 업데이트 및 드라이버를 다운로드하여 설치합니다. 그리고 더 이상 필요하지 않다고 생각하는 프로그램과 애플리케이션은 제거합니다. 새 파일은 기존의 파일을 변경하는데 때로는 더욱 좋지 않게 변경할 수도 있습니다. 대부분의 경우 애플리케이션의 자체 제거 유틸리티를 실행해도 완전히 제거되지 않습니다. 애플리케이션의 일부가 여전히 남게 됩니다. OS에서는 사용자가 설정한 작업을 완료하기 위해 이러한 변경 사항과 교착 상태를 탐색해야 합니다.
이러한 변경 사항 중 일부는 운영 체제에 선택 사항일 수 있는 반면, 다른 변경 사항은 운영 체제에 필수 요소일 수 있습니다. 소프트웨어와 파일은 시간이 지나면서 변하며, 이러한 변화가 성능에 악영향을 주는 경우가 상당히 많습니다.
시간이 지남에 따라 랩톱 또는 데스크톱에서 더 많은 정보, 프로그램 및 데이터를 수집합니다. 하드 드라이브가 커지고 해당 드라이브에 보관하는 데이터양이 증가할수록 성능에 영향을 미치게 됩니다. 하드 드라이브의 파일은 작게 나뉘어 하드 드라이브에 저장됩니다. 이러한 파일은 하드 드라이브에 여유 공간이 있는 곳이면 어디에나 저장됩니다. 즉, 파일을 검색할 때마다 드라이브 전체를 검색하여 다시 결합해야 합니다. 찾아야 할 것이 많고 찾아야 할 부분이 많을수록 속도는 더 느려지게 되는 것은 당연합니다. 이것이 모든 제조업체가 하드 드라이브에서 조각 모음을 실행하는 것과 같은 기본 유지 관리를 따를 것을 권장하는 이유입니다. 가능한 많은 파일 조각을 찾을 수 있도록 드라이브의 파일을 재정렬하여 서로 가까이 있도록 이동시킵니다.
자세한 내용은 조각 모음 및 인접이라는 용어를 검색하십시오.
시간이 지남에 따라 하드 드라이브와 관련된 또 다른 문제는 하드 드라이브에 저장할 데이터가 많을수록 사용 가능한 공간이 적다는 것입니다. 이 여유 공간은 페이징 파일에 사용됩니다. 이것은 가상 메모리 공간을 만들기 위해 랩톱 또는 데스크탑이 하드 드라이브에서 가져오는 공간입니다. 가상 메모리를 사용하여 장치의 RAM(Random Access Memory)이 작동하도록 돕습니다. 이 공간 덕분에 RAM이 프로그램 간에 전환을 더 빠르게 할 수 있습니다. RAM에서 드라이브로 메모리를 캐시하고 가져온 다음 필요할 때 RAM으로 되돌릴 수 있습니다. 이와 관련한 문제를 방지하려면 하드 드라이브가 가득 차지 않도록 합니다. 백업을 실행할 때 가능하면 하드 드라이브에서 불필요한 데이터를 기억하고 제거하십시오.
또 다른 가능한 해결 방법은 솔리드 스테이트(SSD) 하드 드라이브를 노트북이나 데스크탑에 부팅 드라이브로 추가하는 것입니다. 운영 체제에서 부팅하고 실행하는 하드 드라이브입니다. SSD는 읽는 시간이 빠르며 대용량 데이터를 저장하기 위한 의도로 만들어진 것은 아니지만 더 큰 용량의 SSD가 점점 더 일반화되고 있습니다.
하드 드라이브에서 공간을 차지하는 응용 프로그램을 식별하는 특수 프로그램이 있습니다. 일부 프로그램은 장치의 리소스를 사용하는 프로세스 또는 프로그램을 확인합니다. 또한 레지스트리에서 정지 상태거나 연결이 없는 파일 및 불필요한 항목을 확인하는 특수 프로그램도 있습니다. 이러한 프로그램은 유용할 수 있습니다. 불행히도 스파이웨어이며 해당 파일의 기능을 이해하지 않고 파일을 삭제하도록 내버려 두면 그 자체로 문제를 일으키는 것으로도 잘 알려져 있습니다. 이는 랩톱 또는 데스크탑 안정성에 심각한 영향을 미치고 부팅 문제를 일으킬 수 있습니다.
또 다른 소프트웨어 문제는 하드 드라이브에 있는 데이터의 손상입니다. 손상이 충분히 심하면 랩톱 또는 데스크톱의 작동 방식에 영향을 미칩니다. 손상의 원인은 다양합니다. 그러나 대부분은 손상된 RAM 데이터, 정전기, 전원 서지 등 업데이트로 인한 운영 체제 문제입니다. 또는 모든 Windows 사용자가 보고하듯이 시간이 지남에 따른 정상적인 운영 체제 성능 저하에 해당합니다.
우리는 대부분의 사람들에게 맬웨어와 바이러스가 랩톱 또는 데스크톱 속도 저하에 기여한다는 사실을 무시할 수 없습니다. Dell 제품에는 안티바이러스가 사전 설치되어 제공되지만 이를 구성하고 사용할지 여부는 사용자에게 달려 있습니다. 아니면 다른 프로그램을 대신 사용할 수 있습니다. 노트북 또는 데스크탑을 얼마나 자주 스캔하는지, 그리고 온라인 상태일 때 어떻게 행동하는지는 사용자에게 달려 있습니다.
좋은 소식은 운영 체제와 프로그램 및 드라이버를 새로 설치하면 이러한 모든 소프트웨어 문제가 해결된다는 것입니다.
Resolution
설치 가이드 링크
아래 링크 페이지에서 다양한 유형의 Microsoft Windows 운영 체제 설치에 대한 지침을 확인할 수 있습니다.
메모리
문제 및 원인
메모리 문제의 가장 일반적인 징후는 운영 체제가 여러 메모리 오류를 보고하는 것입니다. (예를 들어, 메모리 오버플로우 또는 메모리 부족) 랩톱이나 데스크탑에 RAM이 충분하지 않으면 하드 드라이브가 이를 보완하려고 합니다. 지속적으로 더 많은 RAM을 찾아 다른 작업에서 리소스를 빼앗습니다. 메모리 오류가 계속 발생하지만 메모리가 모든 진단을 통과하는 경우, 장치에 더 큰 메모리 모듈을 추가해야 할 수 있습니다. 일반적으로 사용하는 모든 노트북 또는 데스크탑은 업데이트 및 개발 과정을 거칩니다. 프로그램에는 점점 더 많은 리소스가 필요하게 됩니다. Windows XP에서는 충분했던 RAM 용량은 스트레스를 받을 경우 Windows 11에서 작동하지 않습니다.
- 2014년 4월 8일 이후로 Microsoft는 모든 버전의 Microsoft Windows XP에 대한 지원을 종료했습니다.
- 2017년 4월 11일 이후로 Microsoft는 모든 버전의 Microsoft Windows Vista에 대한 지원을 종료했습니다.
- 2020년 1월 14일 이후로 Microsoft는 모든 버전의 Microsoft Windows 7에 대한 지원을 종료했습니다.
- 2016년 1월 12일 이후로 Microsoft는 모든 버전의 Microsoft Windows 8에 대한 지원을 종료했습니다.
- 2023년 1월 10일 이후로 Microsoft는 모든 버전의 Microsoft Windows 8.1에 대한 지원을 종료했습니다.