Refreshing VMware View fails with error "Unable to fetch data from VCenter: Connection timed out"
Summary:
When trying to access the Protection tab from the user interface, get the below error:
" Error fetching vCenter information for
Reason(s):Unable to fetch data from VCenter:
Connection timed out"
...
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Symptoms
Refreshing VMware View fails with error "Unable to fetch data from VCenter: Connection timed out"
Cause
Communication error with vCenter
Resolution
Confirm that the vCenter is online.
Log in to the vCenter's vSphere web client using the same user account used to add the vCenter to NetWorker.
NOTE: The user account can be seen in the NSR Hypervisor resource:
root@lnx-nwserv:~# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p type: nsr hypervisor
type: NSR hypervisor;
name: vcsa.amer.lan;
version: 7.0.3;
comment: ;
service: VMware VirtualCenter;
endpoint: "https://vcsa.amer.lan/sdk";
username: bkupadmin@vsphere.local;
password: *******;
command: nsrvim;
proxy: lnx-nwserv.amer.lan;
console events: Yes;
cloud: No;
console cancel: Yes;
Snapshot FreeSpace Warning Threshold: 0;
Snapshot FreeSpace Failure Threshold: 0;
restricted data zone: ;
nsradmin>
NOTE: If the vCenter is not accessible from a web browser, consult with the VMware administrator.
Check the NetWorker server can connect to the vCenter:
Use operating system commands to resolve the vCenter name and connect to port 443:
Linux: curl -v vCenter_Name:443
Windows (PowerShell): tnc vCenter_Name -port 443
Optionally, you can use the nsrports command to verify name resolution and port connectivity:
nsrports -t vCenter_Name -p 443
root@lnx-nwserv:~# nsrports -t vcsa.amer.lan -p 443
Forward lookup for vcsa.amer.lan
Query time: 0.001 sec
Canonical name (CNAME): vcsa.amer.lan
Address (A): 192.168.9.111
Connect to port 443: Succeeded (0.000 sec)
Reverse lookup for 192.168.9.111
Query time: 0.001 sec
Name: vcsa.amer.lan
NOTE: If the vCenter server is not accessible over port 443. Consult with the network administrator regarding this connection.
Increase the Inventory Query Timeout:
Additional Information
NVP vProxy: Troubleshooting Network Connectivity For Backup and Restore Operations
NVP vProxy: VMware View does not refresh and all VM backups fail
NVP vProxy: VMware View does not refresh and all VM backups fail
Affected Products
NetWorker Family, NetWorker SeriesArticle Properties
Article Number: 000222673
Article Type: Solution
Last Modified: 01 Mar 2024
Version: 1
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