PowerProtect: Os backups do SQL 2022 falham com o erro Não é possível fazer log-in no SQL Server

Summary: Os backups do SQL 2022 falham devido ao erro "Não é possível fazer logon no SQL Server".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Os backups do SQL 2022 falham com uma mensagem de erro indicando que o provedor não pode ser encontrado.

  • Mensagem de erro "Provider cannot be found. It may not be properly installed" é exibida.
  • O código de erro 800a0e7a é encontrado.
  • A descrição do erro "Unknown error 0x800A0E7A" é exibida.
  • A origem do erro está listada como ADODB. Conexão.
  • Falha na tentativa de conexão com o SQL Server.

Cause

A causa raiz do problema é a incapacidade do PPDM de se conectar ao SQL Server usando a versão 19.x.x.x do driver OLE DB.

    A mensagem de erro também menciona um erro COM com o código 800a0e7a, indicando um problema com o ADODB. Conexão.
    2025-03-18T14:41:51.779Z Tentando se conectar ao SQL Server 'SQLVM\SQL2022' usando o provedor OLEDB:'MSOLEDBSQL'.
    2025-03-18T14:41:51.779Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/nsrsqlado.cpp(1595): Entrando em adoOpenConnectionEx().
    2025-03-18T14:41:51.967Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/ns

    Resolution

    Siga estas etapas para resolver o problema:

    • Instale o driver OLE DB 18.7.4 ou 
    • Instale o driver nativo do SQL.
    Article Properties
    Article Number: 000300476
    Article Type: Solution
    Last Modified: 02 May 2025
    Version:  1
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.