NetWorker. Сбой резервного копирования из-за нехватки устройств для запросов на обслуживание
Summary: В этой статье подробно описывается проблема, связанная с недостаточным количеством устройств (или целевых сессий на устройство), что приводит к сбоям резервного копирования.
Symptoms
Сбой резервного копирования с признаками, указанными ниже, которые указывают на то, что устройство занято и не может завершить резервное копирование:
Error: 'ORA-19511: non RMAN, but media manager or vendor specific failure, error text: busy (0:5:2)'
Error:'ORA-19511: Error received from media manager layer, error text: busy (0:5:2)'
Error: '_nwbsa_is_retryable_error received a retryable network error (Severity 0 Number -13) busy'
Error: 'nsrdasv: Failed to acquire user credentials for direct save nsrmmd auth: busy'
Error: 'save: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'hdbbackint: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'lgto_auth for `nsrmmd' failed: busy'
Cause
Эта проблема обычно возникает, когда устройства заняты обслуживанием других клиентов.
Resolution
Устраните эту проблему, выполнив следующие действия:
- Отключить динамический
nsrmmds.
NMC > Снимите флажок «Динамические nsrmmds» в разделе «Devices>, Storage Nodes, Storage Nodes >», «Properties> ». - Увеличьте количество целевых сеансов устройства, пока проблема не будет устранена.
- Сделайте больше томов (устройств) доступными для резервного копирования, пока проблема не будет устранена.
- Устанавливает уровень отладки
NSR_MAX_START_RETRIES=100для каждого канала.