NetWorker:备份因没有足够的设备来处理请求而失败
Summary: 本文详细介绍了导致备份失败的有关设备不足(或每个设备的目标会话数)的问题。
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
备份失败,并显示以下症状,指示设备正忙,无法完成备份:
Error: 'ORA-19511: non RMAN, but media manager or vendor specific failure, error text: busy (0:5:2)'
Error:'ORA-19511: Error received from media manager layer, error text: busy (0:5:2)'
Error: '_nwbsa_is_retryable_error received a retryable network error (Severity 0 Number -13) busy'
Error: 'nsrdasv: Failed to acquire user credentials for direct save nsrmmd auth: busy'
Error: 'save: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'hdbbackint: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'lgto_auth for `nsrmmd' failed: busy'
Cause
当设备忙于为其他客户端提供服务时,通常会发生此问题。
Resolution
通过执行以下操作解决此问题:
- 禁用动态
nsrmmds管理此进程:
Nmc >DevicesStorage NodesStorage > Node >Properties> 取消选中“Dynamic nsrmmds” - 增加设备的目标会话数,直至问题得到解决。
- 使更多卷(设备)可用于备份,直到问题得到解决。
- 已设置
NSR_MAX_START_RETRIES=100对于每个通道。
Affected Products
NetWorker Module for Databases and ApplicationsProducts
NetWorker, NetWorker Module for Databases and Applications, NetWorker Module for SAPArticle Properties
Article Number: 000167090
Article Type: Solution
Last Modified: 25 Mar 2026
Version: 4
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