VxRail: ОШИБКА vCenter VAMI: Ошибка «Не удается получить состояние развертывания»

Summary: Интерфейс управления устройством vCenter (VAMI) не может получить состояние развертывания. Это может произойти из-за сбоя системы доменных имен (DNS), разрешений для файлов, поврежденных fbInstall.json или отсутствия файлов с нулевым байтовым маркером. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Выявлены проблемы при доступе к VAMI и vCenter

Ошибки доступа к VAMI

  • При попытке открыть VAMI возвращается сообщение об ошибке "Unable to get deployment status.”
Unable to get deployment status

Индикаторы загрузки и конфигурации vCenter.

  • Файл с именем failed Появляйтесьв /var/log/firstboot/.
  • Содержимое файла failed Указать файл "Failed to configure network.”
  • vCenter не удается проверить связь с DNS-сервером.

Журналы управления приложениями

  • Журнал /var/log/vmware/applmgmt/applmgmt.log содержит запись "INSTALL_IN_PROGRESS"
... INSTALL_IN_PROGRESS ...

fbInstall.json Файловые аномалии

  • Файл fbInstall.json существует в /var/log/firstboot/ но может иметь неверные разрешения (не 644 ).
  • Содержимое JSON показывает значение хода выполнения, отличное от 100 или значение "status", отличное от "success".
{
    "progress": 85,
    "status": "in_progress"
}

Обновить файлы каталога

  • В /var/log/vmware/upgrade/, Ожидаемые файлы Prechecks-succeeded, Exports-succeededи Import-succeeded отсутствуют или не равны нулю килобайт.

Cause

Основные факторы, приводящие к тому, что VAMI «Не удается получить состояние развертывания»

  • Сбой при разрешении DNS: VAMI не может получить доступ к требуемым службам, если серверу vCenter не удается выполнить команду ping или разрешить DNS-сервер.
  • Ошибка конфигурации сети при первой загрузке. В /var/log/firstboot/Сбой, в файле отображается "Failed to configure network.”
  • Неправильные разрешения для файлов /var/log/firstboot/fbInstall.json Кроме 644 (rw-r--r--), процесс установки не будет считывать ход выполнения и информацию о состоянии.
  • В журналах отображается ход установки. Наличие «INSTALL_IN_PROGRESS» в /var/log/vmware/applmgmt/applmgmt.log Показывает, что развертывание не завершено.
  • Повреждено или не полно fbInstall.json Отсутствующие или неправильно сформированные поля "progress" (не 100) или "status" (не "success") приводят к тому, что VAMI сообщает о неопределенном состоянии развертывания.
  • Отсутствующие файлы нулевого байта в /var/log/vmware/upgrade/ Отсутствие Prechecks-succeeded, Exports-succeededИли Import-succeeded Это означает, что необходимые шаги не были записаны как выполненные.

Resolution

Войдите в VAMI и проверьте конфигурацию DNS.

Первоначальная проверка доступа

Попытайтесь открыть интерфейс VAMI, используя прямой IP-адрес:

https://:5480/configurev2

Если ошибка "Unable to get deployment status», выполните следующие действия.

Проверка DNS

Внимание! Неправильные настройки DNS могут помешать дальнейшим действиям по развертыванию. Прежде чем продолжить, проверьте возможность подключения.

Проверьте журналы первой загрузки на наличие сетевых ошибок.

Найдите файл сбоя.

# List files in the firstboot log directory
ls -l /var/log/firstboot/

# If a file named "failed" exists, display its contents
cat /var/log/firstboot/failed

Если файл содержит "Failed to configure network,” убедиться, что vCenter может выполнить проверку связи с DNS-сервером и исправить все ошибки в конфигурации сети.

Проверьте состояние управления приложениями.

Найдите текущую установку.

# Look for the INSTALL_IN_PROGRESS flag
grep -i "INSTALL_IN_PROGRESS" /var/log/vmware/applmgmt/applmgmt.log

Проверить fbInstall.json

# Verify the file exists
ls -l /var/log/firstboot/fbInstall.json

# Confirm permissions are 644 (rw-r--r--)
ls -ltrh /var/log/firstboot/fbInstall.json

# Review the JSON content
cat /var/log/firstboot/fbInstall.json

В выходных данных JSON убедитесь:

  • "progress" установлено в значение 100
  • "status" установлено в значение "success"

При необходимости перезапустите службу applmgmt.

# Stop the service
service-control --stop applmgmt

# Edit the JSON file (use vi or your preferred editor) to correct any incorrect values
vi /var/log/firstboot/fbInstall.json

# Start the service
service-control --start applmgmt
Примечание. Редактирование файлов JSON следует выполнять с осторожностью. Всегда выполняйте резервное копирование исходного файла перед внесением изменений.

Проверка файлов завершения модернизации.

Проверьте наличие маркеров успешного выполнения нулевого байта.

cd /var/log/vmware/upgrade/
ls -lh

Ожидаемые файлы (по 0 Кбайт):

  • Prechecks-succeeded
  • Exports-succeeded
  • Import-succeeded

Создайте отсутствующие маркеры.

# Add the files using the touch command. Replace <FILE_NAME> with one of the files above, e.g., Prechecks-succeeded
Example: touch Prechecks-succeeded

# Restart the lightweight VAMI web server
Prior to 8.0U3:
/sbin/service vami-lighttp restart

8.0U3 and above:
systemctl restart cap-lighttpd.service
Внимание! перезапуск», vami-lighttp временно прерывает доступ VAMI. По возможности выполните этот шаг во время окна обслуживания.

Окончательная проверка

  • Доступ к VAMI можно получить по адресу https:// :5480/configurev2 и подтвердите, что состояние развертывания загружается без ошибок.
  • Выполните следующую команду, чтобы убедиться, что установка не выполняется:
grep -i "INSTALL_IN_PROGRESS" /var/log/vmware/applmgmt/applmgmt.log || echo "No active installation"
  • Убедитесь, что три файла маркеров успешного выполнения существуют и их размер 0 Кбайт.
  • Проверьте возможность подключения хоста vCenter к DNS-серверу по сети.
Примечание.  Если после выполнения всех шагов проблема не устранена, см. статью Broadcom При доступе к VAMI возвращается ошибка «Не удается получить состояние развертывания»Эта гиперссылка позволяет перейти на сайт за пределами Dell Technologies. или создайте заявку в службе поддержки Dell.

Affected Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000382558
Article Type: Solution
Last Modified: 22 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.