PowerScale: AD Sudo-opdrachten werken niet meer na upgrade

Summary: Bij het upgraden van PowerScale OneFS vragen sudo-opdrachten drie keer om een wachtwoord en vervolgens wordt de opdracht met "sudo: 3 onjuiste wachtwoordpogingen"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De Active Directory-gebruiker (in dit geval is de AD-gebruikersnaam 'PowerScale') in een rol 'Systeembeheerder' staat nog steeds SSH-invoer toe, de opdracht mislukt als volgt:

cluster-1# ssh DOMAIN\\PowerScale@cluster-1
(DOMAIN\PowerScale@cluster-1) Password: 
PowerScale OneFS 9.12.0.1
Could not chdir to home directory /ifs/home/DOMAIN/PowerScale: No such file or directory
cluster-1% sudo -s

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

For security reasons, the password you type will not be visible.

Password: 
Sorry, try again.
Password: 
Sorry, try again.
Password: 
sudo: 3 incorrect password attempts
cluster0-1% 

Fouten in /var/log/auth.log zijn vergelijkbaar met:

2026-01-09T14:08:46.964341-05:00 <4.6> isi-9510-1(id1) sshd[9292]: Accepted keyboard-interactive/pam for DOMAIN\PowerScale from 10.20.48.1 port 31599 ssh2
2026-01-09T14:09:02.165862-05:00 <4.1> isi-9510-1(id1) sudo[9315]: DOMAIN\PowerScale : 3 incorrect password attempts ; TTY=pts/1 ; PWD=/ ; USER=root ; COMMAND=/bin/zs

Cause

Een update naar sudo zorgde ervoor dat Active Directory-gebruikersnamen in hoofdletters mislukten. Let op: dit is alleen voor omgevingen waar Active Directory-gebruikers om een wachtwoord moeten worden gevraagd. Wachtwoordloze sudo-opdrachten zouden niet beïnvloed moeten worden. Prompts die met een wachtwoord zijn beveiligd, bevatten vermeldingen in 'isi_visudo' Vind ik leuk:

DOMAIN\\powerscale ALL=(ALL) PASSWD: ALL

Resolution

PowerScale Engineering heeft dit probleem geïdentificeerd en werkt aan een permanente oplossing. Gebruikers kunnen de gebruikersnaam in Active Directory bewerken zodat deze in kleine letters staat:

Het scherm Eigenschappen

Zoals bij alle Active Directory-bewerkingen kan het enige tijd duren voordat deze zijn doorgevoerd. Als de gebruiker nog steeds niet aan het werk is, start u een logboekverzameling en neemt u contact op met PowerScale Support.

Article Properties
Article Number: 000413077
Article Type: Solution
Last Modified: 12 Jan 2026
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.