Cisco:Unable to install port license

Summary: Unable to install port license due to DNS being configured on the switch

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

customer was attempting to install additional port activation licenses

Unable to install port-license. You may see some of the following symptoms:

switch running 8.1.1 or later

Error when installing license:

no response from license manager

Switch may reboot and create core file:
 

`show cores` Module Instance Process-name PID Date(Year-Month-Day Time) ------ -------- --------------- -------- ------------------------- 1 1 licmgr 3413 2018-03-26 14:47:40 1 1 licmgr 10353 2018-03-26 14:48:12


Following system reset reason appears.

`show system reset-reason` ----- reset reason for module 1 (from Supervisor in slot 1) --- 1) At 958973 usecs after Mon Mar 26 14:48:20 2018 Reason: Reset triggered due to HA policy of Reset Service: licmgr hap reset

%SYSMGR-2-LAST_CORE_BASIC_TRACE: : PID 9980 with message lmreread(non-sysmgr) crashed, core will be saved . %SYSMGR-2-SERVICE_CRASHED: Service "licmgr" (PID 9976) hasn't caught signal 11 (core will be saved). %SYSMGR-2-LAST_CORE_BASIC_TRACE: : PID 10169 with message lmreread(non-sysmgr) crashed, core will be saved . %SYSMGR-2-SERVICE_CRASHED: Service "licmgr" (PID 10164) hasn't caught signal 11 (core will be saved). %SYSMGR-2-LAST_CORE_BASIC_TRACE: : PID 10358 with message lmreread(non-sysmgr) crashed, core will be saved . %SYSMGR-2-SERVICE_CRASHED: Service "licmgr" (PID 10353) hasn't caught signal 11 (core will be saved).

 

Cause

DNS server has been configured on the switch

Resolution

No fix for this issue currently. 

Workaround:

Remove DNS configuration (using no ip-server commands)
Install license and acquire ports
Add DNS configuration back to switch

This issue is documented under bug id CSCvi74768This hyperlink is taking you to a website outside of Dell Technologies.  however some symptoms may vary

Affected Products

Connectrix MDS-Series Firmware 8.X

Products

Connectrix MDS-Series Firmware 8.X, Connectrix MDS-Series Hardware
Article Properties
Article Number: 000055664
Article Type: Solution
Last Modified: 29 Sep 2025
Version:  3
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