NetWorker: risoluzione dei problemi di mounting dei supporti

Summary: Questo articolo ha lo scopo di aiutare i sostenitori e gli amministratori a determinare le cause dei problemi di lettura di un'etichetta su un dispositivo a nastro o su un disco.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Se la configurazione della libreria ha funzionato in precedenza e improvvisamente si verifica un problema, considerare le possibili modifiche che potrebbero influire sulle letture delle etichette e sui montaggi:

  • Modifica del firmware, del driver o della configurazione del robot, dell'interruttore o dell'adattatore
  • Aggiunta, sostituzione o rimozione di unità, cartucce a nastro o altri componenti della libreria
  • Modifiche o eventi a qualsiasi componente di crittografia (ad esempio, Decru o key manager di crittografia)
  • Modifica della versione del software NetWorker o delle patch del sistema operativo
  • Qualsiasi evento hardware, ad esempio interruzione dell'alimentazione o riavvio di qualsiasi componente nel percorso dati
  • Discrepanze tra la configurazione e la libreria di NetWorker (ad esempio, cartucce a nastro spostate al di fuori del controllo di NetWorker)

Se l'etichettatura o il mounting del volume non ha mai funzionato, verificare che l'hardware dell'unità sia supportato nella NetWorker Hardware Compatibility Guide. Ricorda che è possibile che un dispositivo sia parzialmente funzionante; Il rilevamento da solo non garantisce l'usabilità o il supporto.
 

  • Errori sporadici o costanti nel tentativo di caricamento o mounting di supporti
  • Impossibile eseguire operazioni di mounting o etichettatura su supporti specifici
  • Impossibilità di utilizzare correttamente supporti rimovibili o basati su disco
  • Supporti statici, ad esempio dispositivi basati su disco non utilizzati
  • Volumi contrassegnati come "unlabeled" nell'oggetto NSR Jukebox
  • Volumi il cui campo posizione è contrassegnato come NULL nonostante si trovino in una libreria a nastro
  • Errori di montaggio, etichettatura o scansione dei supporti:
    • "Unexpected volume, wanted <volume_name>, got <different_volume_name>"
    • "Unexpected volid, wanted <mm_volid>, got <different_volid>
    • "Duplicate volume name `<volume_name>'. Select a new name or remove the original volume."
    • "scanner: Read -1 bytes"
    • "scanner: unexpected file number, wanted 2, got <different_number>"
    • "Opening the file '<disk_device_path>/volhdr' failed ([5004] nothing matched)"
    • "Waiting for <number> writable volume(s) to backup pool '<pool>' disk(s) or tape(s) on <storage_node>"
    • Warning: Required volume <volume>'s status is off-line"

    Un'operazione di "mount" di NetWorker è costituita da diverse operazioni secondarie. Esaminare per determinare la fase del mount in cui si verifica l'errore:

    1. NetWorker seleziona un volume per l'operazione: Consultare Risoluzione dei problemi di selezione dei supporti in NetWorker per ulteriori dettagli.
    2. NetWorker carica il volume selezionato nel dispositivo, se necessario: Vedere Risoluzione dei problemi di caricamento della libreria a nastro in NetWorker per ulteriori dettagli.
    3. Provare a leggere l'etichetta:
      • Dispositivo disco: il volhdr File di etichette nella radice della directory del dispositivo disco
      • Periferica a nastro (dopo l'operazione di caricamento): riavvolgimento e lettura Inizio supporto Blocco di etichette da 32 KB
      • Periferica a nastro (dopo la scrittura, inattivo, già caricato) - backspace di un file e lettura dell'intestazione del blocco del primo record
    4. Se la lettura dell'etichetta non riesce per qualsiasi motivo, NetWorker impedisce l'uso del volume in qualsiasi tentativo di riprova:
      • Disco o periferica a nastro standalone: smonta il volume
      • Periferica a nastro della libreria: scaricare il volume, aggiornare la voce dell'etichetta di volume nell'oggetto jukebox nsr a *- (non nell'indice dei supporti) e aggiornare il campo della posizione del database dei supporti su NULL
    5. Se la lettura ha esito positivo, confrontare i dettagli dell'etichetta con i valori "previsti" (quelli nel record del volume del database dei supporti per il volume selezionato):
      • Nome volume
      • ID volume
      • Tipo di supporto
      • Pool
    6. Se convalidato, il volume viene "montato" e considerato disponibile per le operazioni di lettura o scrittura da NetWorker:
      • Per l'oggetto dispositivo nsr che esegue il mounting vengono aggiornati i campi del volume (ad esempio il nome del volume, l'ID del volume e così via).
      • Se i volumi (e il dispositivo) sono membri di una libreria a nastro, i campi appropriati dell'oggetto jukebox nsr vengono aggiornati (ad esempio volumi caricati, slot caricati, codici a barre caricati).
    7. Se la convalida non riesce, viene restituito un errore "imprevisto":
      • "Volume inaspettato, cercasi <volume_name>Ottenuto <different_volume_name>"
      • "Inaspettato volidvolevo <mm_volid>Ottenuto <different_volid>
      • Periferica a nastro della libreria: scaricare il volume e aggiornare la voce dell'etichetta di volume nell'oggetto jukebox nsr a *- (non nell'indice dei supporti)

    I supporti di montaggio sono logicamente separati e distinti dai supporti di caricamento . Il caricamento si applica esclusivamente all'operazione logica (e potenzialmente fisica) di spostamento dei supporti in un dispositivo. Problemi crescenti nella convalida del supporto e della relativa etichetta e nel renderlo logicamente disponibile per l'uso da parte di NetWorker. Operazioni di libreria (nsrlcpd / NSR Jukebox) riguardano i mapping unità:host:handle del dispositivo e lo spostamento fisico. Operazioni dell'unità (nsrmmd / NSR Device) gestiscono tutti gli I/O delle periferiche a nastro di lettura e scrittura. Le operazioni di lettura e scrittura delle etichette sono gestite da nsrsnmd. Pertanto, quelli che sembrano errori di caricamento della libreria possono essere errori di mount dell'unità, dei supporti o del database dei supporti (o viceversa).

    Nota: Per i supporti del disco già montati, una nuova sessione di salvataggio causa nsrmmd Per verificare l'etichetta prima di procedere con le scritture del flusso di salvataggio. Se il controllo dell'etichetta del tempo di salvataggio ha esito negativo, ciò può causare l'annullamento periodico del mount dei volumi basati su disco.

    Inoltre, questo semplice riepilogo non include la rappresentazione della logica di selezione del volume, del nodo o del dispositivo.
     

    Cause

    Le possibili cause degli errori di lettura delle etichette sono diverse:

    • Volume danneggiato
    • Etichetta sovrascritta dal riavvolgimento
    • Problemi di ordinazione delle unità
    • Mancata corrispondenza del database dei supporti
    • Bug CDI
    • Impossibile decrittografare un volume crittografato
    • Problemi di rete o ambientali che causano un errore temporaneo di lettura del file volhdr
    • Incompatibilità tra la libreria libDDBoost e le versioni di DD OS

     

    Resolution

    Per risolvere i problemi di lettura e montaggio delle etichette, dopo aver considerato le ultime modifiche note (se presenti), passare alla procedura di risoluzione dei problemi devolvendo il processo ai suoi costituenti primitivi e testandoli singolarmente.

    Sebbene i dati utili siano raccolti da NSRGet, la maggior parte di queste operazioni richiede l'esecuzione manuale.
     

    AVVISO: Alcuni di questi comandi possono causare reimpostazioni SCSI, che a loro volta possono causare il riavvolgimento delle periferiche a nastro. Non utilizzare se sono presenti nastri attivi accessibili all host.

    Robotica bibliotecaria: comunicazioni

    • Assicurarsi nuovamente che la libreria sia reattiva e pronta prima di procedere. In caso contrario:

    Caricamento della libreria senza mount: funzionamento logico e ordinamento delle unità

    Una volta stabilito che le operazioni fisiche sono prive di errori (almeno superficialmente), possiamo tentare di rintracciare il problema all'interno di NetWorker.

    • Scaricare tutte le cartucce a nastro da tutti i dispositivi della libreria: è fondamentale assicurarsi che sia montato un solo volume per evitare confusione.
    nsrjb [<-j library_name>] -HH
    - or -
    nsrjb [<-j library_name>] -uvvvvv
    • Determinare il layout della libreria e garantirne l'idoneità, confrontando le informazioni sullo stato del jukebox NSR con le informazioni sulle cartucce a nastro del robot:
    nsrjb [<-j library_name>] -C
    sjirdtag <changer address>
    • Tentare di caricare (senza eseguire il mount) un nastro interessato in un'unità interessata con un livello di dettaglio elevato, quindi verificare che l'handle dell'unità indichi la presenza di un volume:
    nsrjb [<-j library_name>] -lnvvvvv -f <device_handle> -S <slot_number>
    mt -f <device_handle> status
    

    mt Conferma che la maniglia del dispositivo non segnala alcun volume. Ciò indica in genere problemi di ordinamento delle unità, soprattutto se appare caricato un handle imprevisto. Continuare invece con la sezione Risoluzione dei problemi di ordinamento delle unità con NetWorker .

    Lettura dell'etichetta del supporto: verifica logica

    • Eseguire una verifica dell'etichetta standalone, per verificare se l'errore di lettura dell'etichetta è temporaneo o coerente:
    nsrmm -pvvvvv -f <device_handle>
    1. Contrassegnare il dispositivo caricato in modalità di servizio per evitare che venga disinstallato
    2. Eseguire il comando: scanner -nvvvvvv <device_handle> (acquisizione su file e annullamento dopo 10 secondi)
    3. Esaminare l'output dello scanner per gli elementi chiave:
    8936:scanner: scanning LTO Ultrium-3 tape 3FO3GR02 on /dev/rmt0.1
    96367:scanner: volume id xxxxxxxx record size 262144 bytes created  7/10/13  1:01:24 expires  7/10/15  1:01:24
    9003:scanner: /dev/rmt0.1: rewinding
    9067:scanner: Rewinding done
    8973:scanner: setting position from fn 0, rn 0 to fn 2, rn 0
    9000:scanner: /dev/rmt0.1: opened for reading

    Lettura delle etichette dei supporti: Verifica fisica (nastro)

    Se la verifica non riesce sia per lo scanner che per nsrmm -p, verificare che l'inizio del nastro sia formattato correttamente:
    • Riavvolgere il nastro utilizzando lo standard mt comando (porta disponibile anche in Windows): mt -f <device> rewind
    • Scaricare ed eseguire il t_reader utility ed estrazione (utilizzare la piattaforma appropriata - sono tutti inclusi). t_reader è disponibile su NetWorker Tools  (richiede l'accesso all'account di supporto Dell)
    • Eseguire l'utilità, fornendo l'handle locale e, facoltativamente, la dimensione del blocco più grande sul nastro, ad esempio:
    t_reader/t_reader_AIX /dev/rmt0.1 262144
    • Lasciare scorrere per alcuni secondi per ottenere una schermata piena di output. Verificare che l'inizio del nastro sia formattato come un'etichetta NetWorker con le dimensioni dei blocchi di dati previste:
    Found block size: 32768 
    File Mark encountered
    Found block size: 32768
    File Mark encountered

    Se la struttura dell'etichetta sembra essere intatta, verificare se può essere letta o se sembra crittografata o compromessa in altro modo:

    dd if=<device> of=<output file> bs=32768 count=2

    L'etichetta deve contenere in testo normale il nome del volume, l'ID del volume e il pool, se leggibile e non crittografato.

    Per ulteriori informazioni, vedere Come utilizzare l'utilità t_reader .

    Lettura etichetta supporto: Verifica fisica (disco)

    Se la verifica non riesce sia per lo scanner che per nsrmm -p, controllare l'integrità del file di etichette di NetWorker, volhdr:

    • Verificare che il file volhdr sia accessibile dall host dello storage node che presenta problemi:
      • Se il dispositivo disco è un AFTD locale, assicurarsi che l'account configurato nella risorsa nsr device sia in grado di leggere e copiare il volhdr file.
      • Se il dispositivo disco è un CIFS/NFS remoto, assicurarsi che l'account configurato nella risorsa nsr device sia in grado di leggere e copiare il volhdr file.
    • Se il volhdr Il file è presente e leggibile, aprirlo e controllare: L'etichetta deve contenere in testo normale il nome del volume, l'ID del volume e il pool, se è leggibile e non crittografato.
    AVVISO: Gestione automatica dei supporti. Se manca un'etichetta di un nastro, un dispositivo con Auto Media Management abilitato etichetta automaticamente il supporto quando necessario. Quando un nastro è privo di etichetta, un dispositivo con Auto Media Management abilitato ne assegna automaticamente una. Per impostazione predefinita, la funzionalità di etichettatura di Auto Media Management è disabilitata per i dispositivi basati su disco.


    Se i test dell'etichetta sopra descritti hanno esito positivo per i dispositivi e i supporti interessati, ma le operazioni di caricamento (e mount) continuano a non riuscire in produzione, fare riferimento a Troubleshooting Tape Library Load Problems in NetWorker per continuare la risoluzione dei problemi.

    Se nessuno dei suggerimenti di cui sopra aiuta, contattare il supporto del fornitore della libreria in modo appropriato se le prove raccolte dal debug suggeriscono anomalie interne, come in Risoluzione dei problemi di rilevamento delle librerie a nastro in NetWorker e Risoluzione dei problemi di accesso alle librerie a nastro in NetWorker; in caso contrario, assicurarsi che l'output di debug venga sottoposto a escalation all'interno del supporto di NetWorker per individuare la possibilità di un difetto di codice.

    Additional Information

    kA2j0000000R6jFCAS_5_0
    Questo articolo fa parte della serie Risoluzione dei problemi dei supporti con NetWorker. L'elenco è qui:
    NetWorker: Troubleshooting Tape Libraries home page

    Affected Products

    NetWorker

    Products

    NetWorker
    Article Properties
    Article Number: 000071880
    Article Type: Solution
    Last Modified: 15 Jul 2026
    Version:  6
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.