How To Resolve High CPU Usage with Dell.Genoa.Agent.exe and Dell.Genoa.UserProcess.exe When Dell SupportAssist for Business is Installed
Summary: When Dell SupportAssist for Business is Installed with Dell.Genoa.Agent.exe and Dell.Genoa.UserProcess.exe, the computer may experience High CPU Usage.
Symptoms
Affected Products:
- Dell Insights
- Dell SupportAssist for Business
Affected Versions:
- v2.1.4 and Earlier
Affected Platforms:
- Windows 10
Dell SupportAssist for Business contains a component that is called Dell Insights, which pull various telemetry information from the endpoint for use by administrators within the Dell TechDirect console. This telemetry data is pulled using various Windows Performance Counters, and in rare situations those performance counters may become corrupted. This article discusses the methods to reset those counters to resolve issues that may come from corrupted or damaged Windows Performance Counters.
Cause
In rare situations, the Windows Performance Counters may become corrupted or damaged, resulting in the Dell.Genoa.Agent.exe or the Dell.Genoa.UserProcess.exe consuming heavy resources. Affected computers show high CPU usage with the Dell.Genoa.Agent.exe or the Dell.Genoa.UserProcess.exe processes. High memory usage (more than 500 MBs) is also a cause.
Resolution
The Windows Performance Counters can be flushed, to resolve. The following steps should be performed in order, to ensure that data is properly flushed. There is an example script that can be used in a .bat file at the bottom. For any questions or concerns with running this manually, contact to Dell ProSupport.
- Stop the Dell Insights Agent service.
- Example Syntax:
net stop DellInsightsAgent
- Example Syntax:
- Flush the Windows Performance Counters.
- Example Syntax (32-bit Operating System):
C:\Windows\system32\lodctr.exe /R - Example Syntax (64-bit Operating System):
C:\Windows\syswow64\lodctr.exe /R
- Example Syntax (32-bit Operating System):
lodctr should be run twice, depending on the state of the device. Dell Recommends running lodctr, flushing the WMI performance counters, and then running lodctr again. For more information about the Windows Performance Counters, reference https://support.microsoft.com/en-us/help/300956/how-to-manually-rebuild-performance-counter-library-values
- Flush the WMI Performance Counters.
- Example Syntax:
winmgmt.exe /resyncperf
- Example Syntax:
- Restart the WMI Service.
- Example Syntax:
net stop Winmgmt /y
- Example Syntax:
- Remove all existing logs for Dell Insights.
- Example Syntax:
RMDIR /s /q "C:\ProgramData\Dell\Dell Insights\"
- Example Syntax:
Re-Start the Dell Insights Agent service.- Example Syntax:
net start DellInsightsAgent
- Example Syntax:
Example Script
::creating logging directory mkdir C:\ProgramData\Dell\InsightsLogging\ ::starting logging ECHO "" >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ECHO Flushing Performance Counters >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ECHO %DATE%%TIME% >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log :stopping Insights service net stop DellInsightsAgent >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::killing process in case the service fails to stop (can happen when in a loop) taskkill /im Dell.Genoa.Agent.exe /f >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::flushing performance counters C:\Windows\system32\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log C:\Windows\syswow64\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log winmgmt.exe /resyncperf >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::stopping services net stop Winmgmt /y >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::re-flushing to validate caches are truly flushed C:\Windows\system32\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log C:\Windows\syswow64\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log winmgmt.exe /resyncperf >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::re-starting services net start Winmgmt >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log net start vmms >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log net start CcmExec >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log net start iphlpsvc >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::purging logs RMDIR /s /q "C:\ProgramData\Dell\Dell Insights\" >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::re-starting insights agent net start DellInsightsAgent >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
- Must be run as an administrator.
- Outputs the status of each line item during the process
- Resets all Windows Performance Counters
- Flushes the existing logs for the Dell Insights Agent, which is a part of Dell SupportAssist for Business
To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
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