Dell Hardware Diagnostics Service (APJ only)

Summary: This article provides information about Dell hardware diagnostic services available in the APJ region.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Thank you for inquiring about our Dell Hardware Diagnostics service. When you have booked this service, you can be sure that your computer is going to be professionally diagnosed by Dell-certified technicians and a Dell representative will contact you to explain the repair costs before making any repairs.

Cause

The reason to send in your computer for diagnostics is to have it professionally diagnosed by Dell-certified technicians to help identify any potential hardware issues when your Dell computer does not seem to be working correctly.

Resolution

The end-to-end process should take 12 - 15 business days from the date of the pickup.


What happens next?

  1. You are contacted to arrange the collection date of your computer. If you are not available at the time of scheduled pickup, the courier leaves a label with instructions for you to arrange another collection date.
  2. Back up your data and remove any confidential or proprietary information.
    • The Dell Repair Center may have to reinstall a copy of your original operating system during the repair resulting in data loss.
  3. Remove or disable the computer password.
    • Failure to remove the password could prevent the repair center from completing the repair and delay returning the computer.
  4. Remove accessories except for your AC-Adapter.
    • Do not ship memory cards, flash drives, CD drives, or any other device.
    • Dell recommends including your AC-Adapter in the box with your personal computer.
  5. On receipt into Dell’s repair facility, a certified Dell Technician will diagnose your computer and a Dell representative makes three attempts to contact you at your specified email and/or your contact number/s provided in relation to your repair quote.
    • If no response within 5 working days, Dell sends your computer back unrepaired.
    • Dell will only proceed with the repair once payment has been received.
    • In the case where you decide not to proceed with the repair, Dell's initial diagnostics service fee is nonrefundable and your computer will be returned unrepaired without further charge.
  6. Dell provides a 90-day guarantee on the replaced parts.
  7. Note Dell reserves the right to use refurbished parts and turnaround time is subject to parts availability.
Article Properties
Article Number: 000132785
Article Type: Solution
Last Modified: 19 Apr 2026
Version:  9
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