ECS: Błąd GeoDrive 12175 - Aplikacja napotkała błąd wewnętrzny podczas ładowania bibliotek SSL
Summary: GeoDrive - Błąd z ECS - 12175 - błąd ładowania bibliotek SSL | Aplikacja napotkała wewnętrzny błąd podczas ładowania bibliotek SSL | Brak instalacji.
Symptoms
Zgłoszenie klienta 12175 — podczas ładowania bibliotek SSL wystąpił błąd wewnętrzny aplikacji.
Rozwiązanie opisano w Podręczniku użytkownika napędu Dell EMC® GeoDrive™ dla systemu Windows w wersji 2.0. UWAGA:
przed rozpoczęciem dochodzenia sprawdź "Dozwolone protokoły HTTPS" w zaawansowanych ustawieniach połączenia hostów.
Czasami wyświetlany jest ten sam komunikat o błędzie "Aplikacja napotkała błąd wewnętrzny podczas ładowania bibliotek SSL". Może się tak zdarzyć, gdy w zaawansowanych ustawieniach połączenia hostów są zaznaczone opcje "SSL 2.0" i "SSL 3.0".
Te ustawienia nie są domyślnie włączone, ale mogą zostać włączone przez pomyłkę.
W celu sprawdzenia ustawień:
- Kliknij opcję "Hosts" na górnym pasku
- Wybierz swojego hosta i kliknij "Edit"
- Wybierz kartę "Zaawansowane"
Poniższy rysunek przedstawia domyślne ustawienie dla "SSL 2.0" i "SSL 3.0" jako niezaznaczone .
Jeśli jest zaznaczona, spróbuj wyłączyć "SSL 2.0" i "SSL 3.0", usuwając zaznaczenie i ponownie testując połączenie.
Instalacja certyfikatu
serwera chmuryW przypadku odebrania komunikatu o błędzie zabezpieczeń 12175 o następującej treści: "Funkcja nie zna urzędu certyfikacji, który wygenerował certyfikat serwera", zainstaluj certyfikat serwera na kliencie GeoDrive w następujący sposób:
1. Po kliknięciu przycisku "Test" GeoDrive wyświetla komunikat o błędzie bezpieczeństwa, który zawiera również szczegóły certyfikatu.
2. Sprawdź, czy nazwa hosta jest taka sama jak nazwa podana przez usługodawcę. Ponadto, że pole host/IP jest wprowadzane podczas konfiguracji serwera (patrz Tabela 3 na stronie 11). Jeśli nie, przed kontynuowaniem potwierdź poprawną nazwę u usługodawcy. W razie potrzeby usuń nieprawidłową nazwę hosta, wprowadź prawidłową nazwę w polu Host/IP, kliknij przycisk "Add", a następnie kliknij przycisk "Test".
3. Jeśli pojawi się okno dialogowe z informacją o powodzeniu, procedura jest zakończona. Łączność z chmurą jest oznaczona zieloną ikoną na stronie głównej GeoDrive.
4. Jeśli ten sam komunikat o błędzie zostanie wyświetlony ponownie, kliknij przycisk Zainstaluj. GeoDrive zainstaluje certyfikat SSL na komputerze lokalnym i zostanie wyświetlony komunikat o powodzeniu.
5. Kliknij przycisk OK. Bezpieczne połączenie z serwerem jest oznaczone zieloną ikoną na stronie głównej GeoDrive.
W systemie Windows 2016 Server opcja instalacji nie jest wyświetlana:
Cause
W systemie Windows 2016 znajduje się funkcja wzmacniania serwera w rejestrze ustawionym pod adresem:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002
Ze względu na już istniejący wpis Oprogramowanie prosi o "kolejną" instalację klucza. Bo to już jest:
Resolution
W przypadku zwykłych instalacji klucz rejestru w funkcji wzmacniania zabezpieczeń serwera nie jest dostępny:
Dlatego rozwiązaniem jest znalezienie poniższego klucza w rejestrze:
"HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002" i usunięcie (lub zmiana nazwy). To rozwiązuje problem. Certyfikat można teraz zainstalować na serwerze, którego dotyczy problem, przy użyciu certyfikatu SSL:
Additional Information
Widzieć: Przechwytywanie dzienników
WinHTTPDzienniki WinHTTP mogą być używane do rozwiązywania problemów z aplikacjami WSDAPI. Jest to przydatne w przypadku niepowodzenia wymiany metadanych lub niepowodzenia negocjacji SSL/TLS.
W tej procedurze pokazano sposób przechwytywania dzienników WinHTTP na komputerze klienckim. Aplikacja kliencka oparta na WSDAPI nie może być uruchomiona, gdy jest włączone rejestrowanie. Jeśli aplikacja kliencka jest uruchomiona w momencie włączenia rejestrowania, klient i komputer muszą zostać ponownie uruchomione przed WS-Discovery. Ruch związany z wymianą metadanych pojawia się w dziennikach WinHTTP.
Aby przechwycić dzienniki WinHTTP.
- Otwórz okno wiersza poleceń z podwyższonym poziomem uprawnień na komputerze klienckim.
- Uruchom następujące polecenie: netsh winhttp set tracing trace-file-prefix="C:\Temp\dpws" level=verbose format=ansi state=enabled max-trace-file-size=1073741824
- To polecenie włącza rejestrowanie WinHTTP. Wszystkie pliki dziennika są przechowywane w katalogu C:\Temp, a nazwy plików zaczynają się od prefiksu dpws. Przechowywane jest maksymalnie 1 GB plików dziennika.
- Jeśli proces korzystający z protokołu WinHTTP na kliencie jest już uruchomiony, uruchom ponownie komputer. Jeśli na przykład są używane interfejsy API odnajdywania funkcji, komputer musi zostać uruchomiony ponownie. Interfejsy API odnajdywania funkcji wywołują protokół WinHTTP z hosta usługi, który mógł już zostać uruchomiony po włączeniu śledzenia.
- Uruchom aplikację kliencką opartą na WSDAPI. Debugowana aplikacja lub można użyć klienta debugowania WSD.
- Odtwórz awarię aplikacji.
- Zakończ działanie aplikacji klienckiej opartej na WSDAPI.
- Jeśli proces korzystający z protokołu WinHTTP nie zostanie zakończony z aplikacją kliencką, uruchom ponownie komputer. Jeśli na przykład są używane interfejsy API odnajdywania funkcji, komputer musi zostać uruchomiony ponownie.
- Uruchom następujące polecenie: netsh winhttp set tracing state=disabled
- To polecenie wyłącza rejestrowanie WinHTTP.
- Sprawdź dzienniki DPWS w folderze C:\Temp i sprawdź, czy wysłano wymagane żądania i komunikaty.
- Jeśli używana jest komunikacja bezpiecznym kanałem (HTTPS), sprawdź, czy nie występują błędy SSL/TLS.
Po przechwyceniu dzienników WinHTTP można je sprawdzić w celu wyszukania przyczyny awarii aplikacji WSDAPI. Edytor tekstu używany do wyświetlania tych dzienników musi być uruchomiony jako administrator. Aby uzyskać więcej informacji, zobacz Korzystanie z rejestrowania WinHTTP w celu zweryfikowania ruchu Get.