Instabilität des PowerFlex-SDS-Prozesses führt zu I/O-Fehlern
Summary: SDS reagiert wiederholt nicht, was zu I/O-Fehlern führt, da der SDS nicht aus dem System evakuiert wird.
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Symptoms
Bei MDM-Ereignissen kann es zu wiederholten SDS-Trennungen (wiederholte Entkopplung) kommen, wobei möglicherweise Anwendungen und SDCs I/O-Fehler melden. SDS-Instabilität wird in den MDM-Ereignissen beobachtet:
# grep ee9b4eb200000002 events.txt | egrep -v "(OSC|SDC_CON|SDC_DISC)" 4284507 2020-10-26 23:38:02.330 SDS_RECONNECTED INFO SDS: sds-********v004 (ID ee9b4eb200000002) reconnected 4284546 2020-10-26 23:38:17.103 SDS_RECONNECTED INFO SDS: sds-********v004 (ID ee9b4eb200000002) reconnected 4284674 2020-10-26 23:40:12.318 SDS_RECONNECTED INFO SDS: sds-********v004 (ID ee9b4eb200000002) reconnected
Der SDC trennt die Verbindung zum SDS, z. B. zu ESXi:
vmkernel.0:2020-10-27T04:01:01.193Z cpu56:66319)WARNING: [14896504445] Disconnected from SDS with ID ee9b4eb200000002 vmkernel.0:2020-10-27T04:01:02.296Z cpu32:66320)WARNING: [14896505547] Connected to SDS with ID ee9b4eb200000002 vmkernel.0:2020-10-27T04:01:18.232Z cpu35:66319)WARNING: [14896521482] Disconnected from SDS with ID ee9b4eb200000002 vmkernel.0:2020-10-27T04:01:19.332Z cpu35:66319)WARNING: [14896522582] Connected to SDS with ID ee9b4eb200000002 vmkernel.0:2020-10-27T04:01:34.769Z cpu53:66320)WARNING: [14896538017] Disconnected from SDS with ID ee9b4eb200000002
I/O-Fehler wird auf SDC angezeigt:
2020-10-27T03:38:02.752Z cpu32:66313)WARNING: ScaleIO mapVolIO_ReportIOErrorIfNeeded:491 :[14895126141] IO-ERROR Type TEST_AND_SET. comb: 55880098015. offsetInComb 2721096. SizeInLB 1. SDS_ID 0. Comb Gen 4619. Head Gen 4b30. StartLB ad48. 2020-10-27T03:38:02.752Z cpu32:66313)WARNING: ScaleIO mapVolIO_ReportIOErrorIfNeeded:512 :Vol ID 0x735105ff0000001c. Last vol network error status NOT_CONN(4) Reason (ABORTED) RC (ABORTED) Retry count (5) chan (0) . . . 2020-10-27T04:08:20.234Z cpu35:66313)WARNING: ScaleIO netCon_IsKaNeeded:3761 :CON 0x439dc29f6700 didn't receive message for 30 iterations. Marking as down 2020-10-27T04:08:20.234Z cpu18:66894)WARNING: ScaleIO netSock_RcvIntrn:1920 :Error: Failed to receive 128 data PTR 0x439dc29f5efc socket 0x439dc29f6418 2020-10-27T04:08:20.234Z cpu33:66806)WARNING: ScaleIO netSock_RcvIntrn:1920 :Error: Failed to receive 128 data PTR 0x439dc29f817c socket 0x439dc29f8698 2020-10-27T04:08:20.234Z cpu0:66879)WARNING: ScaleIO netSock_RcvIntrn:1920 :Error: Failed to receive 128 data PTR 0x439dc29f6a7c socket 0x439dc29f6f98 2020-10-27T04:08:20.234Z cpu23:66319)WARNING: [14896943442] Disconnected from SDS with ID ee9b4eb200000002 2020-10-27T04:08:23.246Z cpu37:65868)Res6: 2346: All helpers quiesced (12 cancelled) for vol 'SD4W21AVxFlexCU03': 1280 LFBCs, 20/1 buckets allocated (4 KB), 1 flush, 0 helpers
Wenn SDS wiederholt getrennt und wieder verbunden wird, tritt wahrscheinlich das im Wissensdatenbank-Artikel beschriebene Problem auf. Im folgenden Beispiel führt ein NVDIMM-Hardwareproblem (HW) zu einem SIGBUS-Fehler (schlechter Speicherzugriff) und verursacht einen SDS-Absturz mit Signal 7. exp.0:
26/10 23:37:55.305617 Termination due to signal 7. PID 2601 Faulting address 0x7efb85004000. errno 0 26/10 23:37:55.306321 Writing backtraces for all UMTs: 26/10 23:38:10.132585 Termination due to signal 7. PID 99889 Faulting address 0x7f5485004000. errno 0 26/10 23:38:10.133167 Writing backtraces for all UMTs:
Meldungen:
Oct 26 23:37:55 kernel: mce: Uncorrected hardware memory error in user-access at 3d84e04440 Oct 26 23:37:55 kernel: MCE 0x3d84e04: Killing sds-3.0.1000.20:2601 due to hardware memory corruption Oct 26 23:37:55 kernel: MCE 0x3d84e04: dax page page recovery: Recovered Oct 26 23:37:55 kernel: sds-3.0.1000.20:4006 conflicting memory types 3d84e04000-3d84e05000 uncached-minus<->write-back Oct 26 23:37:55 kernel: reserve_memtype failed [mem 0x3d84e04000-0x3d84e04fff], track uncached-minus, req uncached-minus Oct 26 23:37:55 kernel: Could not invalidate pfn=0x3d84e04 from 1:1 map Oct 26 23:37:56 sh: abrt-dump-oops: Found oopses: 1 Oct 26 23:37:56 sh: abrt-dump-oops: Creating problem directories Oct 26 23:37:56 sh: abrt-dump-oops: Not going to make dump directories world readable because PrivateReports is on Oct 26 23:37:56 systemd: Configuration file /opt/nsr/admin/networker.service is marked executable.
Cause
- Software(SW)- oder HW-Fehler führen dazu, dass der SDS-Prozess nicht mehr reagiert und die Verbindung zum MDM getrennt wird.
- SDS wird nach dem Absturz wiederhergestellt und übergibt die "Neukonfigurationsphase", in der dieses SDS aus Sicht des MDM und für alle anderen Systemkomponenten, einschließlich SDC, als allgemein verfügbar gekennzeichnet wird.
- Nach 15 Sekunden versucht der SDC erneut, die I/O zu starten (Standardeinstellung), während der SDS erneut nicht reagiert, wie in Punkt "1" beschrieben.
- I/O-Vorgänge schlagen nach Zeitüberschreitung fehl und die SDC-Anwendung meldet einen I/O-Fehler.
- Die Schritte "2", →"4" können wiederholt auftreten, bis dieser SDS aus dem System evakuiert wird.
Resolution
Das System funktioniert wie vorgesehen.
Möglichkeit 1:
Entfernen Sie den SDS aus dem Cluster. Sie können einen SDS jederzeit ohne Ausfallzeiten entfernen. Während des Entfernens werden die zugehörigen Daten auf verschiedene Nodes repliziert. Der Entfernungsprozess ist asynchron und kann viel Zeit in Anspruch nehmen.
Beheben Sie die HW- und SW-Probleme, die die SDS-Instabilität verursacht haben, und geben Sie den SDS an den Cluster zurück.
Möglichkeit 2:
Überwachen Sie das System und beenden Sie den SDS-Service, indem Sie den folgenden Befehl auf dem SDS ausführen, wenn der SDS unter ähnlichen Umständen ausfällt:
Hinweis: Das Beenden des SDS-Service löst einen erneuten Aufbau aus. Sobald das Problem behoben ist, starten Sie den SDS-Service neu, indem Sie den folgenden Befehl auf dem SDS ausführen:
Möglichkeit 1:
Entfernen Sie den SDS aus dem Cluster. Sie können einen SDS jederzeit ohne Ausfallzeiten entfernen. Während des Entfernens werden die zugehörigen Daten auf verschiedene Nodes repliziert. Der Entfernungsprozess ist asynchron und kann viel Zeit in Anspruch nehmen.
Hinweis: Wenn Volumes die Kapazität dieses SDS verwenden und die Kapazität nicht ersetzt werden kann, weil kein freier Speicherplatz verfügbar ist, schlägt das Entfernen fehl.
Beheben Sie die HW- und SW-Probleme, die die SDS-Instabilität verursacht haben, und geben Sie den SDS an den Cluster zurück.
Möglichkeit 2:
Überwachen Sie das System und beenden Sie den SDS-Service, indem Sie den folgenden Befehl auf dem SDS ausführen, wenn der SDS unter ähnlichen Umständen ausfällt:
/opt/emc/scaleio/sds/bin/delete_service.sh
Hinweis: Das Beenden des SDS-Service löst einen erneuten Aufbau aus. Sobald das Problem behoben ist, starten Sie den SDS-Service neu, indem Sie den folgenden Befehl auf dem SDS ausführen:
/opt/emc/scaleio/sds/bin/create_service.sh
Additional Information
Ausfallsicherheit für diese Art von Ereignis ist für die PowerFlex-Softwareversion 4.0 geplant.
Affected Products
PowerFlex rack, VxRackArticle Properties
Article Number: 000181511
Article Type: Solution
Last Modified: 07 May 2026
Version: 3
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