Platformy Dell dla przedsiębiorstw: Aktualizacja oprogramowania wewnętrznego Broadcom NetXtreme kończy się niepowodzeniem z powodu niepowodzenia zbierania danych inwentaryzacyjnych

Summary: Próba aktualizacji karty sieciowej (NIC) NetXtreme 5719 i 5720 Broadcom przy użyciu pliku .bin za pomocą polecenia sudo w systemie Linux powoduje błąd "Inventory Collection Failure".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Poniżej przedstawiono oczekiwany komunikat podczas próby aktualizacji.

Proces aktualizacji
Proces aktualizacji po pomyślnym zakończeniu procesu
zakończony powodzeniemJednak zamiast tego oczekiwanego komunikatu uruchomienie pliku .bin aktualizacji powoduje wyświetlenie następującego komunikatu.

Proces aktualizacjiProces aktualizacji zakończył się niepowodzeniem


zakończył się niepowodzeniemDotyczy to oprogramowania wewnętrznego w wersji 22.91.5.
 
 

Cause

Podczas procesu aktualizacji funkcja używana do zbierania spisu systemu zwraca zmienną null, co powoduje błąd odwołania do wskaźnika null.

Funkcja, o której mowa, jest zawarta w pakiecie aktualizacji i dotyczy wszystkich platform PowerEdge wyposażonych w procesory Broadcom 5719 lub 5720.

Resolution

Ten problem zostanie rozwiązany w następnej wersji oprogramowania wewnętrznego, zaplanowanej na grudzień 2024 r.

Aby obejść ten problem, uruchom plik .bin jako root.

Affected Products

PowerEdge, Broadcom NetXtreme Family of Adapters
Article Properties
Article Number: 000228045
Article Type: Solution
Last Modified: 08 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.