VNX, Dell EMC Unity: No se pudieron enumerar los objetos en el contenedor. Se denegó el acceso
Summary: VNX, Dell EMC Unity: No se pudieron enumerar los objetos en el contenedor. Se denegó el acceso
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
El usuario recibe el error "Se produjo un error al aplicar información de seguridad a: <RUTA> No se pudieron enumerar objetos en el contenedor. Acceso denegado cuando se intenta modificar/ver la ACL de Windows de una carpeta de recurso compartido CIFS creada con una cuenta de administrador de dominio.
Cause
Esto no es un error. En este caso, la configuración de seguridad de Windows tiene un propietario predeterminado de "UNIX UID=0x0" en la carpeta raíz.
Resolution
Para resolver este problema, se debe cambiar el propietario del objeto yendo a "Avanzado" en la pestaña Seguridad de las propiedades de la carpeta. A partir de ahí, cambie el "Propietario" a una cuenta de administrador de dominio. Siga los pasos que se detallan a continuación:
1. En la carpeta raíz, haga clic con el botón secundario, seleccione Propiedades y seleccione la pestaña Seguridad.
2. Haga clic en Opciones avanzadas.
3. La ventana que aparece debe mostrar el propietario actual. Haga clic en "Cambiar". Aparecerá el cuadro emergente "Select User or Group".
4. En el cuadro de texto, escriba su cuenta de administrador de dominio y presione el botón "Verificar nombres". Su nombre será reemplazado por el nombre "oficial" del sistema (es decir, precedido por el nombre de la computadora y la barra diagonal inversa).
5. Haga clic en Aceptar.
6. El cuadro desaparece y lo envía de vuelta a la ventana Configuración de seguridad avanzada.
7. Aparece una nueva casilla de verificación debajo del propietario, con el texto "Reemplazar propietario en subcontenedores y objetos" Seleccione esta casilla de verificación.
8. También puede marcar la casilla "Reemplazar todas las entradas de permisos de objetos secundarios con entradas de permisos heredables de este objeto".
9. Asegúrese de que aparezca "Todos" en la ventana Entradas de permisos; si no es así, haga clic en Agregar. Se vuelve a mostrar el mismo cuadro que aparece en el paso 4. Escriba everyone, haga clic en "Check Names" y, luego, en "OK".
9. Presione Aplicar.
1. En la carpeta raíz, haga clic con el botón secundario, seleccione Propiedades y seleccione la pestaña Seguridad.
2. Haga clic en Opciones avanzadas.
3. La ventana que aparece debe mostrar el propietario actual. Haga clic en "Cambiar". Aparecerá el cuadro emergente "Select User or Group".
4. En el cuadro de texto, escriba su cuenta de administrador de dominio y presione el botón "Verificar nombres". Su nombre será reemplazado por el nombre "oficial" del sistema (es decir, precedido por el nombre de la computadora y la barra diagonal inversa).
5. Haga clic en Aceptar.
6. El cuadro desaparece y lo envía de vuelta a la ventana Configuración de seguridad avanzada.
7. Aparece una nueva casilla de verificación debajo del propietario, con el texto "Reemplazar propietario en subcontenedores y objetos" Seleccione esta casilla de verificación.
8. También puede marcar la casilla "Reemplazar todas las entradas de permisos de objetos secundarios con entradas de permisos heredables de este objeto".
9. Asegúrese de que aparezca "Todos" en la ventana Entradas de permisos; si no es así, haga clic en Agregar. Se vuelve a mostrar el mismo cuadro que aparece en el paso 4. Escriba everyone, haga clic en "Check Names" y, luego, en "OK".
9. Presione Aplicar.
Additional Information
Puede encontrar información adicional aquí: https://social.technet.microsoft.com/Forums/windowsserver/en-US/db04b57c-7684-4e52-8e1a-5e4407f6e2ab/windows-2012-failed-to-enumerate-objects-in-the-container-access-denied?forum=winserver8gen
Affected Products
VNX/VNXeProducts
Dell EMC Unity Family, VNX/VNXeArticle Properties
Article Number: 000056357
Article Type: Solution
Last Modified: 20 Oct 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.