IDPA: 중복된 경로 169.254.0.1로 인해 노드 이벤트 서비스의 성능이 저하되었습니다.
Summary: 노드 이벤트가 포함된 캐싱된 응답 서비스가 비활성화됩니다. 중복된 경로 169.254.0.1로 인해 노드 이벤트 서비스의 성능이 저하됩니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
RUCK 사전 검사 실패 firmware_readiness을 엽니다.
[ERROR] Firmware pre-upgrade checks failed. [ 10.100.XX.XXX ]: The cached response with Node Event Service is disabled.
Node Event Service is in a degraded state,iDRAC Service Module is not available/active at this time.
Check iDRAC Service Module/iDRAC status.
아래 명령을 실행할 때 idraccache에서 오류가 발생하거나 성능이 저하됩니다.
[root@idpa-esx1:~] /opt/dell/DellPTAgent/tools/pta_call get agent/info
Request sent to DellPTAgent @ https://192.168.100.101:8086
{
"libstorelibit.so": "07.05",
"uptime": "177266 seconds ( 2 days 1 hour 14 minutes 26 seconds )",
"host_pass_thru_ip": "169.254.0.2",
"ism_version": "3.6.0",
"model": "R640 IDPA",
"os_version": "6.7.0 build-17700523",
"process_id": "2101654",
"libstorelibir-3.so": "15.03-0",
"default_server_cert": "true",
"TPM Present": "false",
"MarvellLibraryVersion": "5.0.13.1109",
"servicetag": "D3WCCD3",
"mfr": "Dell Inc.",
"system_uuid": "62dcf7ee-334e-8f96-f507-78ac4426a310",
"status": {
"iSM": "N/A",
"agent": "Error/degraded",
"idracConnection": "OK",
"idraccache": "Error/degraded"
iSM이 실행 중이지만 iDRAC:
PTAgent 디버그 로그와 통신할 수 없습니다. /scratch/log/pta_debug.log
2023/10/23 14:29:33[UTC] [19394369:246258496] WARN - WSManClient::isValidResponse: Http request to host: 169.254.0.1, failed with status code: -4
2023/10/23 14:29:34[UTC] [19394369:246786880] WARN - WSManClient::isValidResponse: Http request to host: 169.254.0.1, failed with status code: -4
2023/10/23 14:29:34[UTC] [19394369:246258496] WARN - ISMMonitor::isISMServiceRunning: Command to check iSM status failed with error code <2>. <ism is active (running limited functionality)
Cause
이 추가 경로는 기존 네트워크 구성을 기반으로 호스트 OS 계층에서 생성됩니다. 이 동작은 일반적으로 ESXi 구성에 여러 정적 경로가 정의된 경우에 나타납니다.
가능한 원인에는 ESXi에서 iDRAC로의 내부 SSH 터널 사용이 포함됩니다.
iSM은 추가 경로를 생성하거나 정의된 추가 경로를 탐지 및 복구하지 않습니다.
Resolution
참고: 이 문제에 대한 수정 사항이 goidpa 툴에 추가되었습니다. 아래 KB에 따라 goidpa를 설치합니다.
그런 다음 ACM에서 다음 명령을 실행합니다.
To check this ptagent run:
./goidpa esx ptagent check
To fix issues with ptagent run:
./goidpa esx ptagent fix
참고: 문제가 지속되면 Dell 지원에 문의하여 추가 지원을 받으십시오.
Additional Information
goidpa 자동화가 실패하는 경우 이 해결 방법에 대한 수동 프로세스는 다음과 같습니다.
주의: 다음에서 169.254.0.1/32 경로를 제거합니다.
vmk0 오직. vmk0에서 다른 경로 제거 또는 다른 경로에서 169.254.xx.xx 경로 제거 vmk 다른 라우팅 문제를 일으킬 수 있습니다.
- 169.254.0.2를 사용하는 iSM이 iDRAC의 169.254.0.1과 통신하지 못하게 하는 ESXi 라우팅 테이블에서 잘못된 항목을 확인합니다.
이 문제가 발생하는 네트워크 환경의 예는 아래와 같습니다. 이 vmk0 네트워크 169.254.0.1/32에 대한 추가 경로에 대한 인터페이스의 게이트웨이 주소입니다.
[root@idpa-esxi:~] esxcli network ip route ipv4 list
Network Netmask Gateway Interface Source
-------------- --------------- ------------- --------- ------
default 0.0.0.0 10.100.10.254 vmk0 MANUAL
10.100.10.0 255.255.255.0 0.0.0.0 vmk0 MANUAL
169.254.0.0 255.255.255.0 0.0.0.0 vmk2 MANUAL
169.254.0.1 255.255.255.255 10.100.xx.xxx vmk0 MANUAL
192.168.100.96 255.255.255.224 0.0.0.0 vmk1 MANUAL
- 항목을 제거하여 iSM과 iDRAC 간의 라우팅 문제를 해결하십시오.
esxcli network ip route ipv4 remove -g 10.100.xx.xxx -n 169.254.0.1/32
- 항목이 제거되었습니다.
[root@idpa-esxi:~] esxcli network ip route ipv4 list
Network Netmask Gateway Interface Source
-------------- --------------- ------------- --------- ------
default 0.0.0.0 10.100.10.254 vmk0 MANUAL
10.100.10.0 255.255.255.0 0.0.0.0 vmk0 MANUAL
169.254.0.0 255.255.255.0 0.0.0.0 vmk2 MANUAL
192.168.100.96 255.255.255.224 0.0.0.0 vmk1 MANUAL
- 추가 경로가 제거되면 PTAgent 및 iSM 서비스를 다시 시작합니다.
/etc/init.d/DellPTAgent restart
/etc/init.d/dcism-netmon-watchdog restart
- 펌웨어 준비 상태를 실행하여 성공 확인
DP4400:
curl -k -i -H "Content-Type:application/json" -X POST https://localhost:8039/dpatools/api/v1/firmware/readinesscheck -d '{"idpaVersion": "2.7", "isRack": false, "hostList": [{"hostIP": "192.168.100.101", "esxiUser": "root", "esxiPassword": "IDPAPASSWORD"}]}'
IDPAPASSWORD = IDPA common password
예:
curl -k -i -H "Content-Type:application/json" -X POST https://localhost:8039/dpatools/api/v1/firmware/readinesscheck -d '{"idpaVersion": "2.7", "isRack": false, "hostList": [{"hostIP": "192.168.100.101", "esxiUser": "root", "esxiPassword": "Idpa_12345"}]}'
출력:
HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:38:41 GMT
[{"id":814402494717874004,"hostIP":"192.168.100.101","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":true,"twoHopIsRequired":false,"invalidFirmwareList":[],"messages":"The IDPA system is ready for firmware update.","links":[]}]
DP5x00/DP8x00:
for i in {1..3}; do curl -k -i -H "Content-Type:application/json" -X POST https://localhost:8039/dpatools/api/v1/firmware/readinesscheck -d '{"idpaVersion": "2.7", "isRack": true, "hostList": [{"hostIP": "192.168.100.10'${i}'", "esxiUser": "root", "esxiPassword": "IDPAPASSWORD"}]}'; done
IDPAPASSWORD = IDPA common password
예:
for i in {1..3}; do curl -k -i -H "Content-Type:application/json" -X POST https://localhost:8039/dpatools/api/v1/firmware/readinesscheck -d '{"idpaVersion": "2.7", "isRack": true, "hostList": [{"hostIP": "192.168.100.10'${i}'", "esxiUser": "root", "esxiPassword": "Idpa_12345"}]}'; done
출력:
HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:39:05 GMT
[{"id":2337625064092707360,"hostIP":"192.168.100.101","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":false,"twoHopIsRequired":false,"invalidFirmwareList":[{"name":"Integrated Remote Access Controller","currentVersion":"3.36.103.36","minimumRequiredVersion":"4.40.10.00"}],"messages":"The IDPA system is ready for firmware update.","links":[]}]HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:39:44 GMT
[{"id":1389413431580575643,"hostIP":"192.168.100.102","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":true,"twoHopIsRequired":false,"invalidFirmwareList":[],"messages":"The IDPA system is ready for firmware update.","links":[]}]HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:40:19 GMT
[{"id":1184184063038749065,"hostIP":"192.168.100.103","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":true,"twoHopIsRequired":false,"invalidFirmwareList":[],"messages":"The IDPA system is ready for firmware update.","links":[]}]
아래 명령을 실행하여 캐시 상태를 확인합니다.
/opt/dell/DellPTAgent/tools/pta_call get agent/info
출력:
Request sent to DellPTAgent @ https://192.168.100.101:8086
{
"mfr": "Dell Inc.",
"servicetag": "D3WCCD3",
"host_epoch_time": "1699148602.56383 (secs.usecs)",
"uptime": "204355 seconds ( 2 days 8 hours 45 minutes 55 seconds )",
"system_uuid": "62dcf7ee-334e-8f96-f507-78ac4426a310",
"model": "R640 IDPA",
"process_id": "2101654",
"libstorelibir-3.so": "15.03-0",
"domain": "esx1-5800-crk.dp.ce.gslabs.lab.emc.com",
"name": "esx1-5800-crk",
"ptagentversion": "2.4.1-3",
"idrac_ethernet_ip": "192.168.100.110",
"os_version": "6.7.0 build-17700523",
"ism_version": "3.6.0",
"MarvellLibraryVersion": "5.0.13.1109",
"libstorelib.so": "07.07",
"host_pass_thru_ip": "169.254.0.2",
"default_server_cert": "true",
"status": {
"iSM": "N/A",
"agent": "OK",
"idraccache": "OK",
"idracConnection": "OK"
},
"idrac_pass_thru_ip": "169.254.0.1",
"api_blocking_enabled": "false",
"os": "VMWare ESXi",
"rest_endpoints": "https://192.168.100.101:8086",
"TPM Present": "false",
"libstorelibit.so": "07.05"
}
Response: status: 200 [OK], size: 1063 bytes, latency: 0.144 seconds.
Affected Products
PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software, PowerProtect DP5900, PowerProtect DP8400
, PowerProtect DP8900
...
Article Properties
Article Number: 000219231
Article Type: Solution
Last Modified: 24 Apr 2025
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.