Integrated Data Protection Appliance: La risposta memorizzata nella cache ha danneggiato la cartella ESXi /tmp piena

Summary: La risposta memorizzata nella cache con il servizio eventi del nodo è danneggiata a causa della cartella ESXi /tmp piena.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Errore di verifica preliminare RPS:

[ERROR] Firmware pre-upgrade checks failed. [ 10.xx.xxx.xx ]: The cached response with Node Event Service is disabled. Il servizio eventi del nodo è in uno stato danneggiato, iDRAC Service Module non è disponibile/attivo in questo momento. Check iDRAC Service Module/iDRAC status.

 

showfru disk
Collecting Data............
Failed to execute DPA CLI command: 503 Service Unavailable
Usage: "showfru -help" for more details.



Per altri controlli firmware_readiness correlati rilevati in RUCK, PowerProtect serie DP e IDPA: L'utilità ChecKer Rapid Upgrade mostra un errore per il controllo "firmware_readiness"

Cause

Cartella ESXi /tmp piena

Nel registro di debug PTA, /scratch/log/pta_debug.log vengono visualizzati i seguenti errori:
 

2023/10/06 15:53:44[UTC] [26119210:194411328] WARN  - RefreshDomainHostNames: Command '/bin/esxcli system hostname get' failed - fork(/bin/esxcli) failed - No space left on device.
2023/10/06 15:55:16[UTC] [26119210:189655872] ERROR - execCmdNewEsxi: Error during command execution. Return value from command output - <255>
2023/10/06 15:55:16[UTC] [26119210:189655872] WARN  - PerformanceMonitor::getMemoryUsed: Unable to retrieve memory performance information. Either the group or the current process name is empty.
2023/10/06 15:56:17[UTC] [26119210:184900416] ERROR - System call terminated abnormally: errno=28
2023/10/06 15:56:17[UTC] [26119210:184900416] ERROR - Following file does not exist : /tmp/3f65d64c-67c0-4e69-ab7c-c9609d7a517f.PTAgent.tmp

 

Resolution

Per risolvere questo problema, procedere come segue:

  1. Pulizia di /tmp su ESXi
  2. Riavviare iSM e PTAgent con i comandi riportati di seguito:
/etc/init.d/DellPTAgent restart
/etc/init.d/dcism-netmon-watchdog restart
  1. Reimpostare l'iDRAC
  2. Inoltre, è possibile riavviare il servizio sfcbd con il seguente comando:
/etc/init.d/sfcbd-watchdog restart
  1. Il controllo agente/info e il controllo firmware/idoneità ora sono entrambi corretti con i seguenti comandi:

 

/opt/dell/DellPTAgent/tools/pta_call get agent/info

DP4400

curl -k -i -H "Content-Type:application/json" -X POST  https://localhost:8039/dpatools/api/v1/firmware/readinesscheck -d '{"idpaVersion": "2.7", "isRack": false, "hostList": [{"hostIP": "192.168.100.101", "esxiUser": "root", "esxiPassword": "IDPAPASSWORD"}]}'

You will get an output like the following:

HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:38:41 GMT

[{"id":814402494717874004,"hostIP":"192.168.100.101","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":true,"twoHopIsRequired":false,"invalidFirmwareList":[],"messages":"The IDPA system is ready for firmware update.","links":[]}]acm-4400-crk-3:~


DP5000/DP8000


for i in {1..3}; do curl -k -i -H "Content-Type:application/json" -X POST https://localhost:8039/dpatools/api/v1/firmware/readinesscheck -d '{"idpaVersion": "2.7", "isRack": true, "hostList": [{"hostIP": "192.168.100.10'${i}'", "esxiUser": "root", "esxiPassword": "IDPAPASSWORD"}]}'; done

HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:39:05 GMT

[{"id":2337625064092707360,"hostIP":"192.168.100.101","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":false,"twoHopIsRequired":false,"invalidFirmwareList":[{"name":"Integrated Remote Access Controller","currentVersion":"3.36.103.36","minimumRequiredVersion":"4.40.10.00"}],"messages":"The IDPA system is ready for firmware update.","links":[]}]HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:39:44 GMT

[{"id":1389413431580575643,"hostIP":"192.168.100.102","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":true,"twoHopIsRequired":false,"invalidFirmwareList":[],"messages":"The IDPA system is ready for firmware update.","links":[]}]HTTP/1.1 200
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: POST, PUT, GET, OPTIONS, DELETE
Access-Control-Max-Age: 3600
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept
Content-Type: application/json
Transfer-Encoding: chunked
Date: Sun, 05 Nov 2023 01:40:19 GMT

[{"id":1184184063038749065,"hostIP":"192.168.100.103","result":"SUCCESS","agentIdracDataCached":true,"agentIsOverallReady":true,"agentIsRunning":true,"agentVersionIsOk":true,"idracInRecoveryMode":false,"idracIsAvailable":true,"idracIsReady":true,"idracLcJobQueueIsClear":true,"ismIsEnabled":true,"ismIsReady":true,"firmwareIsValid":true,"twoHopIsRequired":false,"invalidFirmwareList":[],"messages":"The IDPA system is ready for firmware update.","links":[]}]acm-5800-crk:~



 

 

 

Affected Products

PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software , PowerProtect DP5900, PowerProtect DP8400 ...

Products

PowerProtect DP8900
Article Properties
Article Number: 000219233
Article Type: Solution
Last Modified: 27 Mar 2025
Version:  6
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