IDPA: Chyba "Chyba selhání úlohy firmwaru": Časový limit 9029 při čekání

Summary: Tento článek popisuje řešení problému, ke kterému dochází při spuštění chyby RUCK (PowerProtect-DP-Rapid-Upgrade-Checker) během fáze kontroly ESXi. Tato chyba souvisí se stavem Node Event Service, IRAC Service Module nebo IDRAC. Úloha firmwaru selhala s chybou: Překročení časového limitu 9029 při čekání na dokončení interní úlohy ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nástroj RUCK selže během kontroly firmware_readiness a zobrazí se následující zpráva:
 
Firmware pre-upgrade checks failed. Firmware task failed with error: [9029] timeout while waiting for an internal task to complete. Check Node Event service/IRAC Service Module/IDRAC status and check logs for details.

Cause

Stav modulu iDRAC Service Module (ISM) v systému ESXi může mít následující stavy:- Neaktivní
- Aktivní (nespuštěno)
- Aktivní (spuštěno)

První dva stavy (neaktivní, aktivní (nespuštěno)) brání spuštění upgradu.


Služba ISM se v řadiči iDRAC zobrazuje jako "nespuštěno", jak je vidět níže:

Služba ISM se v řadiči iDRAC zobrazuje jako
 

Resolution

Chcete-li změnit službu ISM do stavu "spuštěno", postupujte podle následujících pokynů:

1 – Přihlaste se do systému ESXi, který hlásí chybu jako uživatel root.
2 – Běh /etc/init.d/dcism-netmon-watchdog status Ověření stavu služby ISM na hostiteli ESXi:

root@idpahypervisor1:~> /etc/init.d/dcism-netmon-watchdog status
iSM is active (not running)

  1. 3. Zkontrolujte uživatelské rozhraní řadiče iDRAC na kartě "iDRAC Settings/Settings" a zkontrolujte stav "Nespuštěno": 

    3. Zkontrolujte uživatelské rozhraní řadiče iDRAC na kartě

    Pokud jsou obě služby ve stavu "Nespuštěno", pokračujte následujícím akčním plánem. Nejsou nutné žádné prostoje:

    1. Přihlaste se k serveru ESXi jako uživatel root.
    2. Zastavte službu dcism v systému ESXi: 
/etc/init.d/dcism-netmon-watchdog stop
  1. Zastavte službu sfcdb-watchdog: 
/etc/init.d/sfcbd-watchdog stop
  1. Restartujte řadič iDRAC:
 /opt/dell/DellPTAgent/tools/ipmitool_static mc reset cold
  1. Počkejte, až se řadič iDRAC znovu zapne.
  2. Spusťte službu sfcg-watchdog: 
/etc/init.d/sfcbd-watchdog start
  1. Počkejte několik minut a zkontrolujte stav služby ISM v systému ESXi a řadiči iDRAC. Měl by se zobrazit jako "running":

    Stav > servisního modulu Stav připojení v hostitelském operačním systému se nyní zobrazuje jako  






     

Additional Information

IP adresu řadiče iDRAC lze zjistit příkazem: 

esxcli hardware ipmi bmc get


Vytvořte tunel v případě, že je IP adresa řadiče iDRAC nastavena jako výchozí: 
Zařízení PowerProtect řady DP a IDPA: DP4400: Jak získat přístup k uživatelskému rozhraní řadiče iDRAC tunelem SSH ze systému ESXi

Případně se přihlaste do řadiče iDRAC pomocí SSH a spusťte příkaz: 

racadm get idrac.servicemodule 


Následující článek popisuje další scénáře stejné chyby:
PowerProtect řady DP a IDPA: Rapid Upgrade Nástroj ChecKer Utility zobrazuje selhání pro kontrolu "firmware_readiness"

Affected Products

PowerProtect Data Protection Appliance
Article Properties
Article Number: 000222521
Article Type: Solution
Last Modified: 17 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.