Cloudeinheit gibt nach mehreren Bereinigungszyklen keinen Speicherplatz frei
Summary: Die Cloudeinheit gibt nach mehreren Bereinigungszyklen keinen Speicherplatz frei.
Symptoms
Dies kann in jeder DD mit aktiviertem Cloud-Tier passieren.
Bei der Cloud-Bereinigung sinkt die Auslastung nicht, wenn viele ausstehende GC-Zyklen vorhanden sind, um Hintergrundlöschvorgänge zu verarbeiten.
Cause
Wenn die Timeouts der Cloudeinheit zu häufig sind, kann die DD keine Hintergrundlöschungen verarbeiten.
EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Timeout was reached EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
Resolution
Im Folgenden sind die möglichen Probleme aufgeführt, wenn eine Cloudeinheit getrennt wird.
- DDFS reagiert nicht oder gerät in einen Fehlerzustand.
- Die Datenverschiebung wird entweder gestoppt oder angehalten.
- Die Cloud-Bereinigung wird entweder abgebrochen oder bereinigt abgelaufene Daten aus dem Cloud-Tier nicht.
- Der Cloud-Abruf funktioniert nicht, nimmt Zeit in Anspruch oder zeigt an, dass Daten nicht gefunden wurden.
Die Cloudeinheit zeigt keinen Auslastungsabfall nach dem Bereinigungszyklus an, wenn sich mehrere ausstehende Zyklen in einem angehaltenen Status befinden. Die Beweise können im Auto-Support gesehen werden.
GC remote delete stats for CP edccloudtier2*: Recent Cumulative Number of delete list containers <cid,offset> processed: 174 1799 Number of delete list containers <cid> skipped: 173 1219 Number of regions to delete: 0 627732657 Number of regions deleted: 8236883 215044853 Bytes deleted: 623322937273 16683421699021 Run time (s): 332316 9324202 Deletion rate (region/s): 24 23 >Pending cycles: 17 17
Führen Sie die folgenden Schritte gemäß dem Szenario aus.
- Überprüfen Sie die Konnektivität mit Cloud-Anbietern und stellen Sie fest, ob
- Es gibt ein Problem mit der Verbindung auf Port (443).
- Namensauflösung des Cloud-Anbieters über DD überprüfen
- Wenn zwischen DD und Cloud-Tier alles in Ordnung ist, wechseln Sie zu DD und prüfen Sie, ob das Dateisystem nicht reagiert oder einen Fehler aufweist.
- Starten Sie die DD neu, um alle nicht reagierenden Prozesse freizugeben, um eine ordnungsgemäße Cloud-Konnektivität zu erhalten und ausstehende GC-Zyklen zu verarbeiten.
- Das Problem wird behoben, indem Sie die Cloud-Konnektivität ordnungsgemäß herstellen und die folgenden Befehle auf DD ausführen, um Hintergrundlöschvorgänge zu stoppen und neu zu starten.
Beenden der asynchronen Löschvorgänge# cloud clean background-delete stop
Starten Sie die Massenlöschvorgänge neu.# cloud clean background-delete start
- Fehler #234809 - Führen Sie ein Upgrade der DD auf 6.1.2.x durch, wenn Sie mehr als eine Cloud-Einheit haben und Probleme mit der Cloud-Bereinigung haben.
Additional Information
Die Cloudeinheit zeigt nach dem Bereinigungszyklus keinen Auslastungsabfall an, wenn mehrere ausstehende Zyklen in einem angehaltenen Status sind. Die Beweise können im Auto-Support gesehen werden.
Vor der Lösung
GC remote delete stats for CP edccloudtier2*: Recent Cumulative Number of delete list containers <cid,offset> processed: 174 1799 Number of delete list containers <cid> skipped: 173 1219 Number of regions to delete: 0 627732657 Number of regions deleted: 8236883 215044853 Bytes deleted: 623322937273 16683421699021 Run time (s): 332316 9324202 Deletion rate (region/s): 24 23 >Pending cycles: 17 17
Nach der Lösung
GC remote delete stats for CP edccloudtier2*: Recent Cumulative Number of delete list containers <cid,offset> processed: 1285 0 Number of delete list containers <cid> skipped: 776 0 Number of regions to delete: 0 0 Number of regions deleted: 165625861 0 Bytes deleted: 11764930559267 0 Run time (s): 19897 0 Deletion rate (region/s): 8313 0 Pending cycles: 1 1
Die Beweise können durch die Analyse mehrerer automatischer Stützen und die ausstehenden GC-Zyklen gesehen werden. Im Folgenden finden Sie einige Beispiele.
autosupport_2018-11-08.out:Pending cycles: 5 5 autosupport_2018-11-13.out:Pending cycles: 6 6 autosupport_2018-11-24.out:Pending cycles: 7 7 autosupport_2018-12-15.out:Pending cycles: 9 9 autosupport_2018-12-16.out:Pending cycles: 10 10 autosupport_2018-12-28.out:Pending cycles: 11 11 autosupport_2018-12-29.out:Pending cycles: 12 12 autosupport_2019-01-11.out:Pending cycles: 13 13 autosupport_2019-01-18.out:Pending cycles: 14 14 autosupport_2019-01-19.out:Pending cycles: 15 15 autosupport_2019-02-05.out:Pending cycles: 16 16 autosupport_2019-02-07.out:Pending cycles: 17 17 autosupport_2019-02-08.out:Pending cycles: 1 1 autosupport_2019-02-09.out:Pending cycles: 1 1 autosupport_2019-02-10.out:Pending cycles: 1 1
Die Timeout-Probleme der Cloudeinheit können in Protokollen oder unter "# alerts show history" angezeigt werden.
INFO: Event posted: m0-1585 (21000631:553649713): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1586 (21000632:553649714): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1587 (21000633:553649715): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1588 (21000634:553649716): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1589 (21000635:553649717): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1591 (21000637:553649719): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1578 (2100062a:553649706): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1579 (2100062b:553649707): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1580 (2100062c:553649708): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1581 (2100062d:553649709): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1582 (2100062e:553649710): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1583 (2100062f:553649711): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1584 (21000630:553649712): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN