클라우드 유닛이 여러 정리 주기 후에도 공간을 확보하지 못함

Summary: 클라우드 유닛은 여러 정리 주기 후에도 공간을 확보하지 않습니다.

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Symptoms

이 문제는 클라우드 계층이 활성화된 모든 DD에서 발생할 수 있습니다.

백그라운드 삭제를 처리하는 데 많은 GC 보류 주기가 있는 경우 클라우드 정리의 사용률이 저하되지 않습니다.

 

Cause

클라우드 유닛 시간 초과가 너무 자주 발생하면 DD에서 백그라운드 삭제를 처리할 수 없습니다.

EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Timeout was reached
EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN

 

Resolution

클라우드 유닛의 연결이 끊어졌을 때 발생할 수 있는 문제는 다음과 같습니다.

  1. DDFS가 응답하지 않는 상태로 전환되거나 패닉이 발생합니다.
  2. 데이터 이동이 중지되거나 일시 중단됩니다.
  3. 클라우드 정리는 중단되거나 클라우드 계층에서 만료된 데이터를 정리하지 않습니다.
  4. 클라우드 리콜이 작동하지 않거나 시간이 걸리거나 데이터를 찾을 수 없다고 표시합니다.

보류 중인 여러 주기가 중지된 응답 상태인 경우 정리 주기 후 클라우드 유닛에 활용도 저하가 표시되지 않습니다. 증거는 자동 지원에서 확인할 수 있습니다.

GC remote delete stats for CP edccloudtier2*:                      Recent       Cumulative
Number of delete list containers <cid,offset> processed:              174            1799
Number of delete list containers <cid> skipped:                       173            1219
Number of regions to delete:                                            0       627732657
Number of regions deleted:                                        8236883       215044853
Bytes deleted:                                                  623322937273    16683421699021
Run time (s):                                                      332316         9324202
Deletion rate (region/s):                                              24              23
>Pending cycles:                                                       17              17

시나리오에 따라 다음 단계를 수행합니다.

  • 클라우드 공급업체와의 연결을 확인하고
    • 포트(443)의 연결에 문제가 있습니다.
    • DD에서 클라우드 공급업체의 이름 확인
    • DD와 클라우드 계층 간에 모든 것이 올바른 경우 DD로 이동하여 파일 시스템이 응답하지 않거나 패닉이 있는지 확인합니다.
    • DD를 재부팅하여 중지된 응답 프로세스를 해제하고 적절한 클라우드 연결을 얻고 보류 중인 GC 주기를 처리합니다.
  • 이 문제는 클라우드 연결을 올바르게 설정하고 DD에서 아래 명령을 실행하여 백그라운드 삭제를 중지하고 다시 시작하면 해결됩니다.
    비동기 삭제 중지
    # cloud clean background-delete stop
    대량 삭제를 다시 시작합니다.
    # cloud clean background-delete start
  • 버그 #234809 - 클라우드 유닛이 두 개 이상이고 클라우드 정리 문제가 있는 경우 DD를 6.1.2.x로 업그레이드합니다.

 

Additional Information

보류 중인 주기가 중지된 응답 상태인 경우 정리 주기 후 클라우드 유닛에 활용도 저하가 표시되지 않습니다. 증거는 자동 지원에서 확인할 수 있습니다.

해결 전

GC remote delete stats for CP edccloudtier2*:                      Recent       Cumulative
Number of delete list containers <cid,offset> processed:              174            1799
Number of delete list containers <cid> skipped:                       173            1219
Number of regions to delete:                                            0       627732657
Number of regions deleted:                                        8236883       215044853
Bytes deleted:                                                  623322937273    16683421699021
Run time (s):                                                      332316         9324202
Deletion rate (region/s):                                              24              23
>Pending cycles:                                                       17              17

해결 후

GC remote delete stats for CP edccloudtier2*:                      Recent       Cumulative
Number of delete list containers <cid,offset> processed:             1285               0
Number of delete list containers <cid> skipped:                       776               0
Number of regions to delete:                                            0               0
Number of regions deleted:                                      165625861               0
Bytes deleted:                                                  11764930559267          0
Run time (s):                                                       19897               0
Deletion rate (region/s):                                            8313               0
Pending cycles:                                                         1               1

증거는 여러 자동 지원을 분석하고 GC 보류 주기를 살펴보면 확인할 수 있습니다. 다음은 몇 가지 예입니다.

autosupport_2018-11-08.out:Pending cycles:                                                      5               5
autosupport_2018-11-13.out:Pending cycles:                                                      6               6
autosupport_2018-11-24.out:Pending cycles:                                                      7               7
autosupport_2018-12-15.out:Pending cycles:                                                      9               9
autosupport_2018-12-16.out:Pending cycles:                                                     10              10
autosupport_2018-12-28.out:Pending cycles:                                                     11              11
autosupport_2018-12-29.out:Pending cycles:                                                     12              12
autosupport_2019-01-11.out:Pending cycles:                                                     13              13
autosupport_2019-01-18.out:Pending cycles:                                                     14              14
autosupport_2019-01-19.out:Pending cycles:                                                     15              15
autosupport_2019-02-05.out:Pending cycles:                                                     16              16
autosupport_2019-02-07.out:Pending cycles:                                                     17              17
autosupport_2019-02-08.out:Pending cycles:                                                      1               1
autosupport_2019-02-09.out:Pending cycles:                                                      1               1
autosupport_2019-02-10.out:Pending cycles:                                                      1               1

클라우드 유닛 시간 초과 문제는 로그 또는 "# alerts show history"에서 확인할 수 있습니다.

INFO: Event posted: m0-1585 (21000631:553649713): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1586 (21000632:553649714): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1587 (21000633:553649715): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1588 (21000634:553649716): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1589 (21000635:553649717): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1591 (21000637:553649719): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1578 (2100062a:553649706): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1579 (2100062b:553649707): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1580 (2100062c:553649708): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1581 (2100062d:553649709): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1582 (2100062e:553649710): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1583 (2100062f:553649711): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
INFO: Event posted: m0-1584 (21000630:553649712): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN

 

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000056238
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  4
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