A unidade de nuvem não libera espaço após vários ciclos de limpeza
Summary: A unidade de nuvem não libera espaço após vários ciclos de limpeza.
Symptoms
Isso pode acontecer em qualquer um dos DD com o nível da nuvem ativado.
A limpeza da nuvem não terá nenhuma queda de utilização se houver muitos ciclos pendentes de GC presos para a exclusão em segundo plano do processo.
Cause
Se os tempos de espera excedidos da unidade de nuvem forem muito frequentes, o DD não poderá processar a exclusão em segundo plano.
EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Timeout was reached EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN
Resolution
Veja abaixo os possíveis problemas quando uma unidade de nuvem é desconectada.
- O DDFS entra em estado de não resposta ou entra em pane.
- A movimentação de dados é interrompida ou suspensa.
- A limpeza da nuvem pode ser abortada ou não limpa os dados expirados do nível da nuvem.
- A recuperação da nuvem não funciona ou leva tempo ou mostra dados não encontrados.
A unidade da nuvem não mostrará uma queda de utilização após o ciclo de limpeza se vários ciclos pendentes estiverem em um estado de resposta interrompida. As evidências podem ser vistas no auto-suporte.
GC remote delete stats for CP edccloudtier2*: Recent Cumulative Number of delete list containers <cid,offset> processed: 174 1799 Number of delete list containers <cid> skipped: 173 1219 Number of regions to delete: 0 627732657 Number of regions deleted: 8236883 215044853 Bytes deleted: 623322937273 16683421699021 Run time (s): 332316 9324202 Deletion rate (region/s): 24 23 >Pending cycles: 17 17
Siga estas etapas de acordo com o cenário.
- Verifique a conectividade com provedores de serviços em nuvem e veja se
- Há qualquer problema com a conexão na porta (443)
- Verifique a resolução do nome do provedor de serviços em nuvem do DD
- Se tudo estiver correto entre o DD e o Cloud Tier, acesse o DD e veja se o file system não responde ou está em pane.
- Reinicialize o DD para liberar qualquer processo que tenha parado de responder e obtenha a conectividade adequada com a nuvem e processe os ciclos de GC pendentes.
- O problema é resolvido tornando a conectividade com a nuvem adequada e executando os comandos abaixo no DD para interromper e reiniciar as exclusões em segundo plano.
Interromper as exclusões assíncronas# cloud clean background-delete stop
Reinicie as exclusões em massa.# cloud clean background-delete start
- Bug #234809 - Faça upgrade do DD para a versão 6.1.2.x se você tiver mais de uma unidade de nuvem e tiver um problema de limpeza da nuvem.
Additional Information
A unidade da nuvem não mostrará uma queda de utilização após o ciclo de limpeza se houver vários ciclos pendentes em um estado que parou de responder. As evidências podem ser vistas no auto-suporte.
Antes da resolução
GC remote delete stats for CP edccloudtier2*: Recent Cumulative Number of delete list containers <cid,offset> processed: 174 1799 Number of delete list containers <cid> skipped: 173 1219 Number of regions to delete: 0 627732657 Number of regions deleted: 8236883 215044853 Bytes deleted: 623322937273 16683421699021 Run time (s): 332316 9324202 Deletion rate (region/s): 24 23 >Pending cycles: 17 17
Após a resolução
GC remote delete stats for CP edccloudtier2*: Recent Cumulative Number of delete list containers <cid,offset> processed: 1285 0 Number of delete list containers <cid> skipped: 776 0 Number of regions to delete: 0 0 Number of regions deleted: 165625861 0 Bytes deleted: 11764930559267 0 Run time (s): 19897 0 Deletion rate (region/s): 8313 0 Pending cycles: 1 1
As evidências podem ser vistas analisando vários auto-suportes e olhando para os ciclos pendentes de CG. Veja abaixo alguns exemplos.
autosupport_2018-11-08.out:Pending cycles: 5 5 autosupport_2018-11-13.out:Pending cycles: 6 6 autosupport_2018-11-24.out:Pending cycles: 7 7 autosupport_2018-12-15.out:Pending cycles: 9 9 autosupport_2018-12-16.out:Pending cycles: 10 10 autosupport_2018-12-28.out:Pending cycles: 11 11 autosupport_2018-12-29.out:Pending cycles: 12 12 autosupport_2019-01-11.out:Pending cycles: 13 13 autosupport_2019-01-18.out:Pending cycles: 14 14 autosupport_2019-01-19.out:Pending cycles: 15 15 autosupport_2019-02-05.out:Pending cycles: 16 16 autosupport_2019-02-07.out:Pending cycles: 17 17 autosupport_2019-02-08.out:Pending cycles: 1 1 autosupport_2019-02-09.out:Pending cycles: 1 1 autosupport_2019-02-10.out:Pending cycles: 1 1
Os problemas de tempo de espera excedido da unidade de nuvem podem ser vistos nos registros ou em "# alerts show history"
INFO: Event posted: m0-1585 (21000631:553649713): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1586 (21000632:553649714): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1587 (21000633:553649715): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1588 (21000634:553649716): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1589 (21000635:553649717): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1591 (21000637:553649719): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1578 (2100062a:553649706): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1579 (2100062b:553649707): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1580 (2100062c:553649708): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1581 (2100062d:553649709): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1582 (2100062e:553649710): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1583 (2100062f:553649711): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN INFO: Event posted: m0-1584 (21000630:553649712): EVT-CLOUD-00001: Unable to access provider for cloud unit edccloudtier2.EVT-OBJ::CloudUnit=edccloudtier2 EVT-INFO::Cause=Cloud profile state is DOWN