VNX: Opzioni file disattivate in Unisphere

Summary: Opzioni file disattivate in Unisphere.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Opzioni dei file VNX disattivate in Unisphere.

 

Cause

La sicurezza è stata interrotta a causa di password errate fornite a sysadmin e nasadmin. Gli account sysadmin e nasadmin non devono contenere caratteri speciali come:
# ! ( ) $  : < > | \

 

Resolution

Creare un utente globale o amministratore "tempadmin" con password "sysadmin"
(si consiglia di utilizzare "\" prima del carattere speciale utilizzato nella password)

# /nasmcd/sbin/naviseccli -User sysadmin -Password oldpassword -scope 0 -h SPA Security -adduser -user tempadmin -password sysadmin -scope 0 -role administrator -type system

WARNING: You are about to create user : tempadmin
Proceed?(y/n) y

Verificare che l'account utente temporaneo sia stato creato:

# /nasmcd/sbin/naviseccli -h spa -user tempadmin -password sysadmin -scope 0 security -list
 Username:  tempadmin
Role:      administrator
Scope:     global

Username:  sysadmin
Role:      administrator
Scope:     global

Rimuovere l'account sysadmin.

# /nasmcd/sbin/naviseccli -User tempadmin -Password sysadmin -scope 0 -h SPA Security -rmuser -user sysadmin -scope 0

Aggiornare i file della cache di sicurezza dell'array Control Station utilizzando nas_storage, il nome utente dell'amministratore dell'array e la password utente corrente (come impostata sull'array):

# nas_storage  l
id   acl    name           serial_number
1    0      XXXXXXXXXXXX    XXXXXXXXXXX


# nas_storage -modify id=<CLARiiON ID> -security

Enter the Global CLARiiON account information
Username: tempadmin
Password: *********             Retype your response to validate
Password: *********
Setting security information for XXXXXXXXXXXXX
done

Accedere a Unisphere con l'account tempadmin e verificare che le opzioni File siano attive.

Ricreare l'account sysadmin

# /nasmcd/sbin/naviseccli -User tempadmin -Password sysadmin -scope 0 -h SPA Security -adduser -user sysadmin -password sysadmin -scope 0 -role administrator -type system

Rimuovere l'account tempadmin.

# /nasmcd/sbin/naviseccli -User sysadmin -Password sysadmin -scope 0 -h SPB Security -rmuser -user tempadmin -scope 0

Verificare che l'utente Tempadmin sia stato rimosso correttamente.

# /nasmcd/sbin/naviseccli -h spa -user sysadmin -password sysadmin -scope 0 security -list

Username:  sysadmin
Role:      administrator
Scope:     global

Per modificare la password dell'account sysadmin, accedere a Unisphere con sysadmin/sysadmin.

  1. Selezionare l'array dall'elenco
  2. Passare a Impostazioni-Utente> globale
  3. Cliccare su sysadmin dall'elenco Users e cliccare su Modify.
  4. Inserire la nuova password e confermare e cliccare su OK.
  5. Disconnettersi e accedere nuovamente con la password sysadmin modificata

 

Affected Products

VNX/VNXe

Products

VNX1 Series, VNX2 Series, VNX/VNXe
Article Properties
Article Number: 000056575
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.