RecoverPoint & RP4VMs: Upgrade or deployment "Failed to save array password in lockbox"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
In either the dm.logs file for the Deployment Manager logs for RecoverPoint, or in the Deployer Tool for RecoverPoint For Virtual Machines, upgrade or deployment may fail with the following error:
Failed to save array password in lockbox
Cause
The scripts used by Deployment Manager and the Deployer tool during upgrade and deployment might not be able to process special characters in passwords correctly when communicating over the network:
. ! < ; # ^ > ( $
. ! < ; # ^ > ( $
Resolution
Workaround:
Remove the special characters from the password of the storage array (in the case of RecoverPoint) or from the vCenter (in the case of RP4VMs), and then try the procedure again.
Remove the special characters from the password of the storage array (in the case of RecoverPoint) or from the vCenter (in the case of RP4VMs), and then try the procedure again.
Affected Products
RecoverPointProducts
RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint for Virtual Machines, RecoverPoint SE, RecoverPoint virtual applianceArticle Properties
Article Number: 000059598
Article Type: Solution
Last Modified: 29 Jul 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.