Avamar: Los respaldos de Exchange fallan con el error "El cliente WinRM no puede procesar la solicitud"

Summary: En este artículo, se proporciona orientación para resolver fallas de respaldo de Exchange en Avamar causadas por problemas de conectividad de PowerShell. Estos errores suelen producirse cuando el plug-in de Exchange no puede establecer una sesión remota de PowerShell con el servidor de buzones de correo. ...

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Symptoms

Los respaldos de Exchange fallan con errores similares a los siguientes: 
2024-05-13 17:00:08 avexvss Error <0000>: Error [exchangesvr.avamar.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic. 
2024-05-13 17:00:08 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.  
2024-05-13 17:00:08 avexvss Error <13077>: Unable to complete backup. 
Al abrir el Shell de administración de Exchange, pueden aparecer los siguientes errores relacionados con PowerShell: 
VERBOSE: Connecting to exchangesvr.domain.com
[exchangesvr.domain.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
    + FullyQualifiedErrorId : PSSessionOpenFailed
VERBOSE: Connecting to exchangesvr.domain.com
VERBOSE: Connected to exchangesvr.domain.com.

Cause

El shell de administración de Exchange se conecta al servidor de Servicios de acceso de cliente (CAS) y solo puede ejecutar comandos desde esa máquina. El plug-in de Avamar Exchange ejecuta comandos de PowerShell en segundo plano para enumerar las bases de datos y recuperar la información del servidor de buzones de correo.

Cuando PowerShell no puede conectarse al servidor de buzones de correo real, supone incorrectamente que el servidor CAS es el servidor de buzones de correo. Esta identificación errónea hace que el respaldo falle.

Resolution

Las fallas remotas de PowerShell pueden tener varias causas raíz.

Revise los siguientes artículos de la base de conocimientos de Microsoft para obtener posibles soluciones:

Si el problema persiste después de aplicar la orientación de los artículos anteriores, utilice la siguiente solución alternativa:

  1. Abra el archivo web.config Archivo ubicado en:

    • C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\
  2. Busque cualquier referencia a:

    • %ExchangeInstallPath%
      %ExchangeInstallDir%
  3. Reemplace estas variables por la ruta absoluta al directorio de instalación de Exchange, por ejemplo:

    • C:\Program Files\Microsoft\Exchange Server\V14

Este cambio garantiza que PowerShell resuelva la ruta correcta durante la inicialización de la sesión remota.

Additional Information

 
 
 
 
 

Affected Products

Avamar, Avamar Plug-in for Exchange VSS
Article Properties
Article Number: 000166281
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  4
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