Avamar:Exchangeバックアップが「WinRMクライアントはリクエストを処理できません」というエラーで失敗する

Summary: この記事では、PowerShell接続の問題が原因で発生するAvamarでのExchangeバックアップの失敗を解決するためのガイダンスを提供します。これらのエラーは通常、Exchangeプラグインがメールボックス サーバーとのリモートPowerShellセッションを確立できない場合に発生します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Exchangeのバックアップが、次のようなエラーで失敗します。 
2024-05-13 17:00:08 avexvss Error <0000>: Error [exchangesvr.avamar.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic. 
2024-05-13 17:00:08 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.  
2024-05-13 17:00:08 avexvss Error <13077>: Unable to complete backup. 
Exchange管理シェルを開くと、次のPowerShell関連のエラーが表示されることがあります。 
VERBOSE: Connecting to exchangesvr.domain.com
[exchangesvr.domain.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
    + FullyQualifiedErrorId : PSSessionOpenFailed
VERBOSE: Connecting to exchangesvr.domain.com
VERBOSE: Connected to exchangesvr.domain.com.

Cause

Exchange 管理シェルは 、クライアント アクセス サービス (CAS) サーバーに接続し、そのコンピューターからのみコマンドを実行できます。Avamar Exchangeプラグインは、バックグラウンドでPowerShellコマンドを実行して、データベースを列挙し、メールボックス サーバー情報を取得します。

PowerShell が実際のメールボックス サーバーに接続できない場合、CAS サーバーがメールボックス サーバーであると誤って想定されます。この誤識別により、バックアップが失敗します。

Resolution

リモートPowerShellの障害には、複数の根本原因が考えられます。

考えられる解決策については、次のMicrosoft KB記事を確認してください。

上記の記事のガイダンスを適用しても問題が解決しない場合は、次の回避策を使用します。

  1. を開きます。 web.config ファイルは次の場所にあります。

    • C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\
  2. 以下への参照を検索します。

    • %ExchangeInstallPath%
      %ExchangeInstallDir%
  3. 次の例のように、これらの変数をExchangeインストール ディレクトリの絶対パス に置き換えます。

    • C:\Program Files\Microsoft\Exchange Server\V14

この変更により、PowerShell はリモート セッションの初期化中に正しいパスを解決するようになります。

Additional Information

 
 
 
 
 

Affected Products

Avamar, Avamar Plug-in for Exchange VSS
Article Properties
Article Number: 000166281
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.