Avamar: Exchange-back-ups mislukken met foutmelding "De WinRM-client kan de aanvraag niet verwerken"
Summary: Dit artikel bevat richtlijnen voor het oplossen van Exchange-back-upfouten in Avamar veroorzaakt door PowerShell-connectiviteitsproblemen. Deze fouten treden meestal op wanneer de Exchange-plug-in geen externe PowerShell-sessie met de mailboxserver tot stand kan brengen. ...
Symptoms
2024-05-13 17:00:08 avexvss Error <0000>: Error [exchangesvr.avamar.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
2024-05-13 17:00:08 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.
2024-05-13 17:00:08 avexvss Error <13077>: Unable to complete backup.
VERBOSE: Connecting to exchangesvr.domain.com
[exchangesvr.domain.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
+ FullyQualifiedErrorId : PSSessionOpenFailed
VERBOSE: Connecting to exchangesvr.domain.com
VERBOSE: Connected to exchangesvr.domain.com.
Cause
De Exchange Management Shell maakt verbinding met de Client Access Services (CAS) -server en kan alleen opdrachten uitvoeren vanaf die computer. De Avamar Exchange plug-in voert op de achtergrond PowerShell-opdrachten uit om databases op te sommen en informatie over de mailboxserver op te halen.
Wanneer PowerShell geen verbinding kan maken met de daadwerkelijke postvakserver, wordt er ten onrechte van uitgegaan dat de CAS-server de postvakserver is. Deze verkeerde identificatie zorgt ervoor dat de back-up mislukt.
Resolution
Externe PowerShell-fouten kunnen meerdere hoofdoorzaken hebben.
Raadpleeg de volgende Microsoft KB-artikelen voor mogelijke oplossingen:
- https://support.microsoft.com/kb/2028305 (externe link)
- https://learn.microsoft.com/en-us/troubleshoot/exchange/administration/winrm-cannot-process-request (Externe link)
Als het probleem zich blijft voordoen nadat u de richtlijnen uit de bovenstaande artikelen hebt toegepast, gebruikt u de volgende tijdelijke oplossing:
-
Open de
web.configBestand bevindt zich op:-
C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\
-
-
Zoek naar verwijzingen naar:
-
%ExchangeInstallPath% %ExchangeInstallDir%
-
-
Vervang deze variabelen door het absolute pad naar de Exchange-installatiemap, bijvoorbeeld:
-
C:\Program Files\Microsoft\Exchange Server\V14
-
Deze wijziging zorgt ervoor dat PowerShell het juiste pad oplost tijdens de initialisatie van externe sessies.