Avamar: Error 52001: Communications Module Scanner Error

Summary: This article reviews Error 52001 (Communications Module Scanner Error) when there are no errors or warnings in the switch monitoring log.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Management Console Service (MCS) alerts report "Communications Module Scanner Error" with no details about the error:

mccli event show |grep -i communications
21181703 2020-11-09 18:02:15 EST ERROR   52001 SYSTEM   PROCESS  /      Communications Module Scanner Error
 

Examining event ID (21181703 in this instance) further:

mccli event show --id=21181703 
0,23000,CLI command completed successfully.
Attribute   Value                                               
ID          21181703
Date        2020-11-09 18:02:15 EST
Type        ERROR
Code        52001
Category    SYSTEM
Severity    PROCESS
Domain      /
Summary     Communications Module Scanner Error
SW Source   HW:COMM
For Whom    All Users
HW Source   xxxxxxxxx
Description The communications module scanner encountered an error while attempting to monitor the network communication modules.
Remedy      Check the communications module scanner log to see what errors were encountered. Validate network connectivity to the communication modules.
Notes       The default IP addresses for the communication modules are: Communications Module A - 192.168.255.200 and Communications Module B - 192.168.255.201.  Please refer to /usr/local/avamar/var/log/switch_monitoring.log for more details.
Data        <data><entry key="hostname" type="text" value="<hostname>" version="1"/><entry key="locationName" type="text" value="Utility Node" version="1"/><entry key="ip" type="text" value="10.n.n.70" version="1"/><entry key="extendedStatus" type="text" value="N/A" version="1"/><entry key="nodeId" type="text" value="0.s" version="1"/><entry key="requestor" type="xml" value="&amp;lt;requestor domain=&amp;quot;/&amp;quot; product=&amp;quot;MCS&amp;quot; role=&amp;quot;Administrator&amp;quot; user=&amp;quot;root&amp;quot;/&amp;gt;" version=""/></data>
 

There are no alerts reported in the switch_monitoring.log (/usr/local/avamar/var/log/switch_monitor.log) at the time of the MCS alert.

 

The mcserver logs (/usr/local/avamar/var/mc/server_log/mcserver.log*) contain the following events:

09/11-18:02:15.00052 com.avamar.mc.mon.HardwareMonitor.monitor
FINE: HW_MON - invoking script...
WARNING: java.io.IOException: process killed due to timeout: /usr/local/avamar/lib/mcs_ssh_wrapper ssh admin@x.x.x.x '/usr/local/avamar/bin/check_switch.rb'
 
 
Warning: Stop using this article if none of the errors or logs match the article.

Cause

The error indicates that the hwmonitor script (check_switch.rb) encountered an error due to the script taking too long to complete, resulting in MCS publishing event code 52001 (Communications Module Scanner Error).

 

Resolution

1. Log in to the Avamar Utility Node as admin.

2. Make a backup copy of the mcserver.xml file:

cp -p /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml /usr/local/avamar/var/mc/server_data/prefs/x-mcserver.xml.`date +%y%m%d`
 

3. Edit the mcserver.xml file:

vi /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
 

4. Update the hwMonitorTimeout and hwMonitorInterval values to match the following:

<entry key="hwMonitorTimeout" value="1800" /> 
<entry key="hwMonitorInterval" value="86400" /> 
 

5. Exit and save the file.

6. Restart MCS per Avamar: How to Restart Management Console Server.

7. Monitor the grid.

 
Note: A permanent fix for this issue should be made available in v19.4.0.83.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000180123
Article Type: Solution
Last Modified: 20 Aug 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.