ECS: GeoDrive - Error 12152 - The server returned an invalid or unrecognized response

Summary: When testing the connectivity of a host by clicking "Test," the below Error is appearing: 12152 - The server returned an invalid or unrecognized response.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When testing the connectivity of a host by clicking "Test," the below Error is appearing:

12152 - The server returned an invalid or unrecognized response


It does no matter what is changed in the existing (Advanced) connection details, like changing SSL settings (ECS: GeoDrive - Error from ECS - 12175 - error loading the SSL libraries | The application experienced an internal error loading the SSL libraries | install is missing), removing/adding ECS IP's/DNS entries or even adding not existing IPs.
The error message remains the same every time.

Another S3 tool like S3Browser can connect to the ECS bucket and download files with no issues.

Cause

If a default proxy server is defined for Windows Server, the settings in GeoDrive might be wrong in this relation.
 

Resolution

Verify if a default proxy server is defined by running the following using the Windows Command line:

netsh winhttp show proxy

 

Go into the Host entry/Advanced tab. Click "Configure Proxy Server."

Uncheck: "Use default proxy...", if defined.

Affected Products

GeoDrive for Windows

Products

ECS, ECS Appliance, Elastic Cloud Storage
Article Properties
Article Number: 000181069
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  2
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