VxRail : Échec du bilan de santé du nœud pour le test « idc_swi » (inventaire des logiciels iDRAC)

Summary: Le test « idc_swi » interroge la lecture de l’inventaire logiciel et renvoie la version actuelle de l’iDRAC.

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Symptoms

Le bilan de santé « idc_swi » s’exécute sur les nœuds ESXi dans le cadre des bilans de santé VxVerify et récupère l’inventaire logiciel à partir de l’iDRAC. Cela garantit que la communication entre ESXi et iDRAC fonctionne correctement et que l’inventaire est analysé pour identifier les versions présentant des problèmes de mise à niveau connus.
 

Résultat du test
Code de résultat
    Interprétation des résultats
Pass
0
Inventaire logiciel lu pour la version actuelle de l’iDRAC
Warning
1
Réponse non valide de l’iDRAC reçue.
Échec 2 Les requêtes iDRAC ont échoué ou un problème susceptible de bloquer une mise à niveau a été détecté.
Critique 3
Ce test n’a pas de résultat critique.


Chaque test réussi n’est pas répertorié dans le rapport récapitulatif, pour en faciliter la lecture.

Vous trouverez ci-dessous un exemple de sortie du bilan de santé, lorsque l’inventaire logiciel a échoué :

#========================#======#=========#====================================================================#==============# 
|  Hostname / Category   |Status  Dell_KB |  Warnings or Failures, unless tests Passed                         ; Product S.N. | 
#========================#======#=========#====================================================================#==============# 
| node01                 | Warning 205769 | idc_swi: iDRAC invalid response: ...                                             .|
| node02                 | Failure 205769 | idc_swi: iDRAC 6.10.80.00 will cause upgrade from 70410 to fail                  .|

Cause

Les tests iDRAC s’appliquent uniquement aux nœuds Dell et sont contournés pour les nœuds virtuels et Quanta.
Ce test interroge la lecture de l’inventaire logiciel et renvoie la version actuelle de l’iDRAC, qui est visible dans le rapport vxtii.txt.

Resolution

L’iDRAC ne répond pas.

  1. Connectez-vous à l’interface utilisateur de l’iDRAC et vérifiez si celle-ci fonctionne et génère des rapports corrects.
  2. Utilisez racadm pour vérifier si la commande racadm swinventory est renvoyée avec succès.
    • La commande suivante peut être exécutée à partir de la console ESXi (cela ne fonctionne pas sur VxRail 8.0.300 ou version supérieure) :
    • ​​​​/opt/vxrail/bin/remotecmd -q -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -o PubkeyAuthentication=yes -o PasswordAuthentication=no -i /etc/ssh/ssh_host_rsa_key -l vxpsvc 169.254.0.1 racadm swinventory
      
  3. Si la commande ne se renvoie pas correctement, réinitialisez ou redémarrez l’iDRAC.
    • Par exemple, pour redémarrer l’iDRAC à l’aide d’ipmitool, reportez-vous à la commande ci-dessous : 
      • /opt/vxrail/tools/ipmitool mc reset cold
        
    • (Pour plus d’informations, consultez l’article 528587 de la base de connaissances VxRail : VxRail : Comment utiliser ipmitool)
  4. Une fois l’iDRAC réinitialisé, effectuez un nouveau test. Si racadm swinventory revient correctement, exécutez à nouveau VxVerify

Affected Products

VxRail Appliance Series

Products

VxRail, VxRail Appliance Family, VxRail Software
Article Properties
Article Number: 000043137
Article Type: Solution
Last Modified: 04 Jul 2025
Version:  7
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