VxRail. Сбой диагностики узла для теста «idc_swi» (инвентаризация программного обеспечения iDRAC)

Summary: Тест «idc_swi» запрашивает возможность чтения инвентаризации программного обеспечения и возвращает текущую версию iDRAC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Диагностика системы «idc_swi» выполняется на узлах ESXi в рамках диагностики системы VxVerify и извлекает данные инвентаризации программного обеспечения из iDRAC. Это гарантирует, что связь между ESXi и iDRAC работает правильно, а инвентаризация анализируется для версий с известными проблемами обновления.
 

Результаты тестирования
Код результата
    Интерпретация результатов
Успех
0
Чтение инвентаризации ПО для текущей версии iDRAC
Предупреждение
1
Получен недопустимый ответ от iDRAC.
Сбой 2 Запросы iDRAC завершились сбоем, или была обнаружена проблема, которая блокирует обновление.
Критический 3
Этот тест не содержит критических результатов.


Для удобства чтения каждый пройденный тест в сводном отчете не указывается.

Пример выходных данных диагностики системы при сбое инвентаризации программного обеспечения показан ниже:

#========================#======#=========#====================================================================#==============# 
|  Hostname / Category   |Status  Dell_KB |  Warnings or Failures, unless tests Passed                         ; Product S.N. | 
#========================#======#=========#====================================================================#==============# 
| node01                 | Warning 205769 | idc_swi: iDRAC invalid response: ...                                             .|
| node02                 | Failure 205769 | idc_swi: iDRAC 6.10.80.00 will cause upgrade from 70410 to fail                  .|

Cause

Тесты iDRAC применимы только к узлам Dell и не выполняются для виртуальных узлов и узлов Quanta.
Этот тест запрашивает возможность чтения данных инвентаризации программного обеспечения и возвращает текущую версию iDRAC, которую можно увидеть в отчете о vxtii.txt.

Resolution

iDRAC не отвечает.

  1. Подключитесь к пользовательскому интерфейсу iDRAC и проверьте, работает ли он и правильно ли создает отчеты.
  2. Используйте racadm, чтобы проверить, успешно ли возвращена команда racadm swinventory.
    • Из консоли ESXi можно выполнить следующую команду (это не работает в VxRail 8.0.300 и более поздних версиях):
    • ​​​​/opt/vxrail/bin/remotecmd -q -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -o PubkeyAuthentication=yes -o PasswordAuthentication=no -i /etc/ssh/ssh_host_rsa_key -l vxpsvc 169.254.0.1 racadm swinventory
      
  3. Если команда не возвращается должным образом, сбросьте или перезагрузите iDRAC.
    • Например, чтобы перезагрузить iDRAC с помощью ipmitool, см. следующую команду: 
      • /opt/vxrail/tools/ipmitool mc reset cold
        
    • (Дополнительные сведения см. в статье базы знаний VxRail 528587: VxRail. Как пользоваться ipmitool)
  4. После сброса iDRAC повторите проверку и Если racadm swinventory возвращает правильно, повторно запустите VxVerify

Affected Products

VxRail Appliance Series

Products

VxRail, VxRail Appliance Family, VxRail Software
Article Properties
Article Number: 000043137
Article Type: Solution
Last Modified: 04 Jul 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.