DPA: DPA report-results/exports directory does not auto-clean up and contains old files

Summary: This article provides the solution when DPA report-results/exports directory does not auto-clean up and contains old files.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

On the Data Protection Advisor (DPA) Application server there is a directory located at the below location
 

<DPA_install_directory>/shared/report-results/exports


Examining this directory it contains old files that can date back days, months or years.  The files appear to be related to reports run in the GUI.


 

Cause

This is a known Bug/Defect in Data Protection Advisor.

The /report-results/exports directory contains export results of dashboards, control panels or of single reports that are run in the DPA GUI.  These export files don't have a lifespan and will remain in the directory forever unless manually removed.

Other directories under /report-results do have a lifespan and are auto-cleaned up (deleted) periodically by DPA.

Resolution

Resolved in Data Protection Advisor 6.2 SP1 with the latest Server patch build.
Resolved in Data Protection Advisor 6.3 and above.

The latest Server Patch Build is available through Dell Technical Support.

The files in the following directories will all be auto-cleaned up (deleted) every 24 hours.
report-results/exports
report-results/temp
report-results/rds

Note the files in report-results/scheduled will not be removed, by design.

Please contact Dell EMC Technical Support for further details or information.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000055103
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  5
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