Connectrix Brocade B-Series: 개인/공개 키를 사용한 SSH 로그인 실패, 공개 키를 가져올 수 없음

Summary: SSH 개인/공개 키 인증에 실패했습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SSH를 사용하여 개인/공개 키 쌍으로 스위치에 로그인하는 경우 작업이 실패하고 비밀번호를 입력하라는 메시지가 표시됩니다.

오류:

Failed to import public key.

 

Cause

Fabric OS v7.4.1d, v8.0.1, v8.0.1a 또는 v8.0.1b를 실행하는 스위치로 공개 키를 가져오면 파일에 연결된 사용자가 파일에 대한 파일 권한을 읽을 수 없음으로 변경했습니다.

Brocade DEFECT000616486

 

Resolution

수리하다:
Fabric OS 7.4.1e 및 Fabric OS 8.0.2 이상으로 업그레이드하십시오.

해결 방법:

  1. 루트 사용자로 로그인하고 chmod를 사용하여 공개 키에 대한 권한을 644로 변경합니다.

  2. chmod 644 /fabos/users/admin/.ssh/authorized_keys.*

    문제가 여전히 지속되면 아래 단계를 따르십시오.

    1. "authorized_keys.admin"(유일한)에 이미 644 권한이 있는지 확인합니다.

       

      switch:root> ls -pal /fabos/users/admin/.ssh
      total 32
      drwxr-xr-x 2 root admin 4096 Mar 29 11:20 ./
      drwxr-xr-x 3 root admin 4096 Mar 23 09:48 ../
      -rw-r--r-- 1 root root 10240 Mar 28 09:21 authorizedKeys.tar
      -rw-r--r-- 1 root admin 759 Mar 28 09:21 authorized_keys
      -rw-r--r-- 1 root admin 759 Mar 28 09:21 authorized_keys.admin
      -rw-r--r-- 1 root admin 134 Feb 1 01:01 environment
    2. 아래 절차에 따라 스위치에 대한 "root" 액세스를 사용하여 관리자의 공개 키를 필요한 위치에 수동으로 복사합니다.
      사용자 관리자에 대한 호스트에서 공개 키 파일을 생성한 경우, 예를 들면 다음과 같습니다.
      switch:root> /home/admin/.ssh/id_dsa.pub
      호스트에서 다음 명령을 사용하여 공개 키가 상주하는 호스트에서 스위치로 SCP(Secure Copy)를 수행합니다. 여기서 스위치 IP 주소는 xx.xx.xx.xx로 제공됩니다.
      scp ~/.ssh/id_dsa.pub root@xx.xx.xx.xx:/fabos/users/admin/.ssh/authorized_keys
      scp ~/.ssh/id_dsa.pub root@xx.xx.xx.xx:/fabos/users/admin/.ssh/authorized_keys.admin
      참고: scp를 사용한 스위치 액세스는 root@xx.xx.xx.xx입니다.

Brocade DEFECT000616486

 

Affected Products

Connectrix

Products

Connectrix, Connectrix B-Series Hardware
Article Properties
Article Number: 000064822
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.