Avamar: ADMe-postvarsler mottas ikke
Summary: ADMe-postvarsler krever verifisering av fire områder, inkludert miljøvariabler og jobbpolicyer, for å sikre riktig konfigurasjon og vellykket levering.
Symptoms
Dette påvirker ikke ADMe-operasjoner annet enn ikke å kunne motta e-postvarsler fra ADMe.
Cause
Følgende fire områder bør verifiseres og oppdateres etter behov for å motta e-postvarsler fra ADMe.
- Variabel for miljøfiler CMD_mail: Må inneholde banen til mailx-programmet
- Variabel for miljøfiler MAIL_TO: Må inneholde de nødvendige mottakernes e-postadresser
- I en jobbpolicydefinisjon må alternativet -m finnes på Tapeout_Flags linjen
- Filnavnet /etc/mail.rc må oppdateres for å sikre at vertsnavnet for SMTP-reléet (Simple Mail Transfer Protocol) er angitt i det.
Resolution
Følgende fire trinn må være på plass og verifisert for å kunne motta e-postvarsler fra ADMe.
- Variabel for miljøfiler CMD_mail: Må inneholde banen til mailx programmet normalt / usr / bin / mailx. Bruk kommandoen
which mailxfor å sjekke om Mailx er installert og for å identifisere banen. - Variabel for miljøfiler MAIL_TO: Må inneholde kommaatskilt komma for de påkrevde mottakerne hvis mer enn én
- I en jobbpolicydefinisjon må alternativet -m finnes på Tapeout_Flags linjen
- Filnavnet /etc/mail.rc må inneholde følgende linje for at mailx skal løse vertsnavnet for SMTP-videresending satt smtp= customers-smtp-relay-hostname
Filen /etc/mail.rc skal ha riktig vertsnavn for SMTP-videresending for at mailx skal fungere skikkelig.
set smtp=customers-smtp-relay-hostnameAdditional Information
For å bekrefte e-postmeldinger kan mottas ved hjelp mailx, kan du kjøre følgende kommandosekvens utenfor ADMe.
1. Ved OS-ledeteksten logget på som rotskriver du inn følgende:
mailx -s "mailx verification test" recipient-email-address
Hello there
Cntrl-D
Dette skal sende en e-post til mottakeren med en emnelinje som inneholder "mailx verification test," og kroppen skal inneholde "Hello there"
Noen ganger er det forsinkelser med postleveringen, så gi den i øst 30 minutter. Hvis du fortsatt ikke mottar e-posten, er det noe galt som er stedsspesifikt, og det krever inngripen fra kunden for å løse.