Dell Help & Support: Application Fails to Launch with 'Failure to Connect to Service' Error Message
This article describes an issue the Dell Help and Support application connecting to the service on launch.
Summary:This article describes an issue the Dell Help and Support application connecting to the service on launch.
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Article Content
Symptoms
Some computers are shipping with an older version of the Dell Help & Support application. When the application is launched, a message stating the application "failed to connect to the service" is observed and the application stops. Reinstalling or updating the application does not resolve the issue.
Cause
An older version of this application can cause this issue.
Resolution
The Dell Help & Support application must be completelyremoved and the latest version reinstalled to resolve this issue.
Press and hold the Windows () key, and then press the e key.
In the address bar at the top, type, C:\ProgramData\Dell\Dell Help & Support, and then press the enter key.
Delete all the files and subfolders in the folder.
Reboot the computer.
Reinstall the latest version of the Dell Help & Support application (the Dell Help & Support application is in the Application category). For more information, see Dell KB article 123347: Drivers and Downloads FAQs.
After installing, wait 5 minutes before attempting to launch the application.