Der Data Protection Advisor-Datenspeicherservice wird bei der Durchführung einer Neuinstallation nicht gestartet

Summary: Der Data Protection Advisor-Datenspeicherservice wird bei der Durchführung einer Neuinstallation nicht gestartet.

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Symptoms

Der Data Protection Advisor-Datenspeicher wurde erfolgreich als Root installiert, danach konnten jedoch die Datenspeicher- und Agent-Services nicht gestartet werden.

Nachfolgend finden Sie die beobachteten Fehler und Warnungen.

Installationsprotokoll:

Installed the datastore service successfully

Command completed successfully.

Completed in : 89ms
[COMMAND EXIT CODE]
FAILURE : 255
[COMMAND OUTPUT]
EMC Data Protection Advisor

Completed in : 1.1secs
[COMMAND ERROR]
[ERROR] Cannot execute command as the service state is unknown. Service must be installed

[INFO] ---- Executing IASetApolloSuperUserPassword ----
[INFO] $CHOSEN_INSTALL_SET$ = (DS)
[INFO] $dpacmd$ = (/opt/emc/dpa/services/bin/dpa.sh)

[INFO] Executing 'dpa ds superpwd'..
[WARN] Executing 'dpa ds superpwd' was failed. The database superuser password was not set.

[INFO] ---- Executing ApolloUserPasswordConsole ----

[INFO] ---- Executing IASetApolloUserPassword ----
[INFO] $CHOSEN_INSTALL_SET$ = (DS)
[INFO] $dpacmd$ = (/opt/emc/dpa/services/bin/dpa.sh)

[INFO] Executing 'dpa ds dspassword'..
[WARN] Executing 'dpa ds dspassword' was failed. The database password was not set.

[COMMAND ERROR]
[ERROR] Failed to start the agent service

=======
# ./dpa.sh ds start --debug

EMC Data Protection Advisor

Environment variables are : []
[DEBUG] su: User not known to the underlying authentication module
[DEBUG] Service Conditions : false true false true
[DEBUG] Service State : UNKNOWN
[ERROR] Cannot execute command as the service state is unknown. Service must be installed

Auch wenn ein Nutzer versucht, die Software zu deinstallieren, entfernt das Deinstallationsprogramm die Dateien, Skripte oder Verzeichnisse nicht.

 

Cause

Hierbei handelt es sich um ein Umgebungsproblem, das nichts mit Data Protection Advisor zu tun hat.

Das Problem steht im Zusammenhang mit Berechtigungen auf dem Linux-Server. Auch wenn der Nutzer "root" sein kann, gibt es Umstände, unter denen dies möglicherweise noch nicht ausreicht. Es kann auch andere Sicherheitssoftware oder Anforderungen auf dem Linux-Server geben. Diese werden von den Administratoren der Linux-Umgebung verwaltet.

In einem Fall wurde beobachtet, dass die Linux-Server mit Sicherheitssoftware konfiguriert waren, die verhinderte, dass das DPA-Installationsprogramm die erforderlichen Benutzer (apollosuperuser) und Gruppen (dpaservices) erstellte, die für die DPA-Datenspeicherdatenbank erforderlich sind.

 

Resolution

Das DPA-Produkt funktioniert wie vorgesehen.

Die Lösung dieses Problems erfordert eine Untersuchung durch die Administratoren der betroffenen Umgebung. Dies sollte ggf. mit dem entsprechenden Anbieter erfragt werden.

Weitere Informationen zu Berechtigungen für die Installation unter Linux finden Sie im DPA-Installations- und Administrationshandbuch. Lesen Sie den Abschnitt Systemanforderungen –> Berechtigungen.

Wenden Sie sich an den technischen Support von Dell, um weitere Details oder Informationen zu erhalten.

 

Products

Data Protection Advisor
Article Properties
Article Number: 000168546
Article Type: Solution
Last Modified: 25 Nov 2025
Version:  4
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