Le service Data Protection Advisor Datastore ne démarre pas lors de l’exécution d’une nouvelle installation

Summary: Le service Data Protection Advisor Datastore ne démarre pas lors de l’exécution d’une nouvelle installation.

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Symptoms

Le magasin de données Data Protection Advisor semblait s’installer avec succès en tant qu’utilisateur root, mais les services du magasin de données et de l’agent n’ont pas pu démarrer par la suite.

Vous trouverez ci-dessous les erreurs et les avertissements observés.

Log d’installation :

Installed the datastore service successfully

Command completed successfully.

Completed in : 89ms
[COMMAND EXIT CODE]
FAILURE : 255
[COMMAND OUTPUT]
EMC Data Protection Advisor

Completed in : 1.1secs
[COMMAND ERROR]
[ERROR] Cannot execute command as the service state is unknown. Service must be installed

[INFO] ---- Executing IASetApolloSuperUserPassword ----
[INFO] $CHOSEN_INSTALL_SET$ = (DS)
[INFO] $dpacmd$ = (/opt/emc/dpa/services/bin/dpa.sh)

[INFO] Executing 'dpa ds superpwd'..
[WARN] Executing 'dpa ds superpwd' was failed. The database superuser password was not set.

[INFO] ---- Executing ApolloUserPasswordConsole ----

[INFO] ---- Executing IASetApolloUserPassword ----
[INFO] $CHOSEN_INSTALL_SET$ = (DS)
[INFO] $dpacmd$ = (/opt/emc/dpa/services/bin/dpa.sh)

[INFO] Executing 'dpa ds dspassword'..
[WARN] Executing 'dpa ds dspassword' was failed. The database password was not set.

[COMMAND ERROR]
[ERROR] Failed to start the agent service

=======
# ./dpa.sh ds start --debug

EMC Data Protection Advisor

Environment variables are : []
[DEBUG] su: User not known to the underlying authentication module
[DEBUG] Service Conditions : false true false true
[DEBUG] Service State : UNKNOWN
[ERROR] Cannot execute command as the service state is unknown. Service must be installed

En outre, lorsqu’un utilisateur tente de désinstaller le logiciel, le programme de désinstallation ne supprime pas les fichiers, les scripts ou les répertoires.

 

Cause

Il s’agit d’un problème environnemental sans rapport avec Data Protection Advisor.

Le problème est lié aux autorisations sur le serveur Linux. Bien que l’utilisateur puisse être « root », il existe des circonstances où cela peut ne pas être suffisant. Il peut également y avoir d’autres logiciels de sécurité ou exigences sur le serveur Linux. Ils sont gérés par les administrateurs de l’environnement Linux.

Dans un cas, il a été observé que les serveurs Linux étaient configurés avec un logiciel de sécurité qui empêchait le programme d’installation de DPA de créer l’utilisateur requis (apollosuperuser) et le groupe (dpaservices) requis par la base de données du datastore DPA.

 

Resolution

Le produit DPA fonctionne comme prévu.

La résolution de ce problème nécessite une procédure d’enquête par les administrateurs de l’environnement concerné. Ce problème doit être examiné auprès du fournisseur approprié, si nécessaire.

Pour plus d’informations sur les autorisations d’installation sous Linux, reportez-vous au Guide d’installation et d’administration de DPA. Consultez la section Configuration matérielle -> Autorisations.

Pour plus d’informations, contactez le support technique Dell.

 

Products

Data Protection Advisor
Article Properties
Article Number: 000168546
Article Type: Solution
Last Modified: 25 Nov 2025
Version:  4
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