Dell EMC VxRail: Bundle konnte während des Upgrades nicht hochgeladen werden, mit dem Fehler „Failed write to datastore“.

Summary: Es wurde das Problem behoben, dass das Bundle während des Upgrades auf 7.0.130 mit dem Fehler „Failed write to datastore“ nicht hochgeladen werden konnte.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Bundle konnte während des Upgrades mit dem Fehler „Failed write to datastore“ nicht hochgeladen werden.
Der Upgradefehler kann mit folgender Meldung auftreten:
„Uploading bundle with exception: java.io.IOException: failed to write to datastore ...“

Screenshot des Cluster-Upgradenavigators beim Auftreten des Problems:
1.png
 
 

Cause

Dies geschieht, nachdem das Upgrade gestartet wurde und versucht wurde, Bundles in den vSAN-Datastore hochzuladen.

Resolution

Befolgen Sie diese Schritte zur Lösung des Problems:
  1. Melden Sie sich bei vCenter an und navigieren Sie zum VxRail-Cluster, für das ein Upgrade durchgeführt wird.
  2. Navigieren Sie zum vSAN-Datastore.
  3. Klicken Sie mit der rechten Maustaste auf den vSAN-Datastore und wählen Sie im Menü die Schaltfläche „Rename“ aus.
  4. Entfernen Sie Zeichen wie %, /, \ aus dem Namen des vSAN-Datastore im Pop-up-Fenster.
  5. Klicken Sie auf die Schaltfläche „OK“, um den Namen des vSAN-Datastore zu speichern.
  6. Gehen Sie zurück zum Upgradenavigator des VxRail-Clusters und klicken Sie auf die Schaltfläche „Retry“.

Additional Information

Die Sonderzeichen %, /, \ können im Namen eines vSAN-Datastore verwendet werden. Ein Datastore-Name mit diesen Zeichen wird in ASCII mit %25, %2f, %5c anstelle von UTF-8 in VC MOB gespeichert. Der Datastore-Name wird in der URL zum Hochladen des Bundles in den vSAN-Datastore nicht korrekt codiert.

Affected Products

VxRail Software

Products

VxRail
Article Properties
Article Number: 000183449
Article Type: Solution
Last Modified: 03 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.