7.7.1.0, 7.7.2.0, 7.8.0.0 ve 7.8.0.10 sürümlerine sahip Data Domain sistemleri. Temizleme döngüsü çalışırken yedeklemeler yazıldığında veri kaybı sorunu ortaya çıkabilir
Summary: DDOS 7.7.1.0, 7.7.2.0, 7.8.0.0 ve 7.8.0.10 sürümlerinin çalıştırıldığı Data Domain sistemleri (DDR'ler, DDVE, bulutta DDVE), nadir görülen bir yarış durumu nedeniyle temizleme işlemi çalışırken yedeklemeler yazdırıldığında veri kaybı sorunuyla karşılaşabilir. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Temizleme döngüsü sırasında veriler sistemden yanlışlıkla silinebilir. Yedekleme artık tamamen geri okunamaz. Bu sorun oluştuğunda, Data Domain Restorer (DDR) aşağıdakilerden birini veya birkaçını sergileyebilir:
- Diskte bozulma bulunduğunu belirten uyarı verilir:
Id Post Time Severity Class Object Message
----- ------------------------ -------- ---------- ----------- ------------------------------------------------------------------
m0-32 Wed Jun 29 05:19:16 2022 CRITICAL Filesystem Tier=Active EVT-FILESYS-00020: Corruption has been detected in the filesystem.
- Etkilenen dosya; geri yükleme, çoğaltma, buluta veri taşıma veya temizleme döngüsü tarafından okunuyorsa Data Domain Dosya Sistemi'nin (DDFS) planlanmamış yeniden başlatmaları görülür.
ETKİ KAPSAMI
- Potansiyel Olarak Etkilenen Sistemler: DDOS 7.7.1.0, 7.7.2.0, 7.8.0.0, 7.8.0.10 sürümlerinin çalıştırıldığı DDR, DDVE, Bulutta DDVE sistemleri. DDOS'un diğer herhangi bir sürümünü çalıştıran sistemler etkilenmez.
- DDOS'un önceki herhangi bir sürümünde yazdırılan mevcut yedeklemeler etkilenmez.
- Veri taşıma kullanılarak bulutta katmanlı hale getirilen yedeklemeler etkilenmez.
- Dosya doğrulama işlemi, son temizlemenin tamamlanma zamanından sonra yedeklemeleri doğrulamışsa ve herhangi bir "Corruption Detected" (Bozulma Algılandı) uyarısı verilmemişse yedeklemelerin etkilenmediği doğrulanmış olur.
- Tüm yedeklemeler başarıyla çoğaltılmışsa bu, Çoğaltma Kaynağı Data Domain'in etkilenmediğini gösterir.
Cause
Sorun, nadir görülen bir yarış durumu nedeniyle oluşmaktadır.
Resolution
Bu sorun, DDOS 7.7.1.10, 7.7.2.10, 7.8.0.20 ve sonraki sürümlerinde giderilmiştir.
Ek düzeltmeleri ve en son güvenlik açığı düzeltmelerini dahil etmek için indirme portalındaki mevcut sürümler arasından seçim yapın.
Aşağıdaki iki bölümdeki adımları takip edin:
(I) Yeni yedeklemelerin etkilenme olasılığını ortadan kaldırma
(II) Veri Bütünlüğünü Doğrulama ve Sorun Giderme.
(I) Yeni yedeklemelerin etkilenme olasılığını ortadan kaldırma
Önerilen eylem, bu soruna yönelik düzeltmeyi içeren bir DDOS sürümü yüklemektir. Düzeltmeye sahip DDOS sürümü kuruluysa bu bölümdeki (I) başka bir işlemin yapılması gerekmez.
VEYA
Düzeltmeye sahip DDOS sürümü hemen yüklenemiyorsa (I) bölümüyle devam edin:
Örnek:
(II) Veri Bütünlüğünü Doğrulama ve Sorun Giderme
Data Domain mimarisi, yazılan tüm yedeklemelerin doğruluk açısından kontrol edilmesini sağlar. Herhangi bir yedekleme, doğrulamayı geçemezse bir uyarı gönderilir. "Last Verified file timestamp" (Son doğrulanan dosyanın zaman damgası) değeri, tüm dosyaların doğrulandığı tarihi/saati gösterir. "Last Verified file timestamp" değeri, son temizleme döngüsünden sonraki bir zamanı gösteriyorsa VE "Corruption Detected" (Bozulma Algılandı) uyarısı yoksa hiçbir yedeklemenin etkilenmediği doğrulanmış olur.
Ek düzeltmeleri ve en son güvenlik açığı düzeltmelerini dahil etmek için indirme portalındaki mevcut sürümler arasından seçim yapın.
Aşağıdaki iki bölümdeki adımları takip edin:
(I) Yeni yedeklemelerin etkilenme olasılığını ortadan kaldırma
(II) Veri Bütünlüğünü Doğrulama ve Sorun Giderme.
(I) Yeni yedeklemelerin etkilenme olasılığını ortadan kaldırma
Önerilen eylem, bu soruna yönelik düzeltmeyi içeren bir DDOS sürümü yüklemektir. Düzeltmeye sahip DDOS sürümü kuruluysa bu bölümdeki (I) başka bir işlemin yapılması gerekmez.
VEYA
Düzeltmeye sahip DDOS sürümü hemen yüklenemiyorsa (I) bölümüyle devam edin:
1. Temizleme zamanlamasını devre dışı bırakın.
2. Kapasite sorununu hafifletmek için temizleme çalıştırılması gerekiyorsa temizleme işlemine başlamadan önce tüm alımları devre dışı bırakın.
# filesys clean set schedule never Filesystem cleaning is scheduled to run "never". Stop current Clean cycle if running # filesys clean status Cleaning started at 2022/06/27 12:32:03: phase 4 of 6 (pre-select) 8.7% complete, 438 GiB free; time: phase 0:00:01, total 0:10:35 # filesys clean stop The 'filesys clean stop' command stops the filesystem cleaning. Are you sure? (yes|no) [no]: yes ok, proceeding.
2. Kapasite sorununu hafifletmek için temizleme çalıştırılması gerekiyorsa temizleme işlemine başlamadan önce tüm alımları devre dışı bırakın.
2a. Yedekleme uygulamasından yedeklemeleri/klonlamayı devre dışı bırakın.
2b. Data Domain'de protokolleri devre dışı bırakın.
2b. Data Domain'de protokolleri devre dışı bırakın.
# replication disable all # nfs disable # cifs disable # ddboost disable # vtl disable
2c. Temizleme işlemini çalıştırın ve aşağıdaki gibi izleyin:
2d. Temizleme işleminde 2. aşamaya (ön analiz) başlandığında yedekleme zamanlamasını ve protokolleri yeniden etkinleştirin.
# filesys clean start Active tier cleaning started. Use 'filesys clean watch' to monitor progress. # filesys clean watch Beginning 'filesys clean' monitoring. Use Control-C to stop monitoring. Cleaning: phase 1 of 6 (pre-merge) 100.0% complete, 438 GiB free; time: phase 0:00:42, total 0:00:42- Cleaning: phase 2 of 6 (pre-analysis) 3.3% complete, 438 GiB free; time: phase 0:00:16, total 0:00:59
2d. Temizleme işleminde 2. aşamaya (ön analiz) başlandığında yedekleme zamanlamasını ve protokolleri yeniden etkinleştirin.
# replication enable all # nfs enable # cifs enable # ddboost enable # vtl enable
NOT: Düzeltmeye sahip DDOS sürümü yüklendikten sonra temizleme zamanlamasını sıfırladığınızdan emin olun.
Örnek:
# filesys clean set schedule Tue,0600
(II) Veri Bütünlüğünü Doğrulama ve Sorun Giderme
Data Domain mimarisi, yazılan tüm yedeklemelerin doğruluk açısından kontrol edilmesini sağlar. Herhangi bir yedekleme, doğrulamayı geçemezse bir uyarı gönderilir. "Last Verified file timestamp" (Son doğrulanan dosyanın zaman damgası) değeri, tüm dosyaların doğrulandığı tarihi/saati gösterir. "Last Verified file timestamp" değeri, son temizleme döngüsünden sonraki bir zamanı gösteriyorsa VE "Corruption Detected" (Bozulma Algılandı) uyarısı yoksa hiçbir yedeklemenin etkilenmediği doğrulanmış olur.
1. Veri bütünlüğü uyarısı verilip verilmediğini kontrol edin:
Uyarı aşağıdaki gibi görünür:
Veri bütünlüğü uyarısı görülürse hemen Dell Technologies Müşteri Desteği ile iletişime geçin.
CRITICAL Filesystem Tier=Active EVT-FILESYS-00020: Corruption has been detected in the filesystem. Check for current alerts with the command below: # alerts show current
Veri bütünlüğü uyarısı görülürse hemen Dell Technologies Müşteri Desteği ile iletişime geçin.
2. Veri bütünlüğü uyarısı yoksa son temizleme işleminin tamamlanma zamanını ve "Last Verified file timestamp" değerini kontrol edin.
2a. Son temizleme işleminin çalıştırılma zamanını kontrol edin:
# filesys clean status Cleaning finished at 2022/06/24 16:36:01.
2b. "Last Verified file timestamp" değerini kontrol edin:
SE moduna girin:
# priv set se Enter system password: <Enter Serial Num> # se grep "Last Verified file timestamp:" /ddr/var/support/autosupport Last Verified file timestamp: Sat Jun 25 23:00:22 2022 Verify threads running: 1
- Last Verified file timestamp değeri, son temizleme döngüsünün tarih ve saatinden daha ileri bir zamanı gösteriyorsa hiçbir yedeklemenin etkilenmediği doğrulanmış olur.
- "Last Verified file timestamp" değeri, son temizleme döngüsünün zamanından bir hafta veya daha kısa bir süre gerideyse lütfen değerin döngü zamanını yakalamasını bekleyin ve tekrar kontrol edin.
NOT: "Last Verified file timestamp" değerinin geride olması, veri bütünlüğü sorunu olduğu anlamına gelmez. Bu yalnızca, "Last Verified file timestamp" tarihinden sonra yazılan dosyaların henüz doğrulanmadığı anlamına gelir.
- Etkilenen DDOS sürümünün çalıştırıldığı tüm sistemlerde (ayrıca düzeltilmiş sürüme yakın zamanda yükseltilen her sistemde) "Last Verified file timestamp" değeri bir haftadan daha uzun süre gerideyse (veya belirlenemiyorsa) veri doğrulama konusunda yardım almak için Dell Technologies Müşteri Desteği ile iletişime geçin.
Article Properties
Article Number: 000200905
Article Type: Solution
Last Modified: 11 Dec 2023
Version: 10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.